Opened 5 months ago

Closed 5 months ago

#30214 closed defect (fixed)

TBA - NPE in ChangeOnionAlphaRunnable

Reported by: sysrqb Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, tbb-8.5-must, TorBrowserTeam201905R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

java.lang.NullPointerException: 
  at org.mozilla.gecko.torbootstrap.TorBootstrapPanel$ChangeOnionAlphaRunnable.run (TorBootstrapPanel.java:77)
  at java.lang.Thread.run (Thread.java:784)

Child Tickets

Change History (6)

comment:1 Changed 5 months ago by sysrqb

It seems like getActivity() is null here :(

 77                  getActivity().runOnUiThread(new Runnable() {                                                                                                                                                  
 78                       public void run() {
 79                           setOnionAlphaValue(newAlpha);
 80                       }
 81                  });

This doesn't seem likely during initial startup, but maybe this is triggering after selecting the Settings cog/gear? Maybe there's a race there?

comment:2 Changed 5 months ago by gk

Do you have steps to reproduce this one (as well)?

comment:3 Changed 5 months ago by sysrqb

Status: newneeds_review

I don't have steps for reproducing it, but I think I have a branch that prevents it. This is only a guess, though. Branch 30214_00 in my repo.

I still think this is happening when the user presses the gear button after they started bootstrapping. This patch tries preventing the race condition where the background thread remains alive after the current activity becomes invalid.

comment:4 Changed 5 months ago by sysrqb

Hmm. I wonder if this is a duplicate of #29982.

comment:5 Changed 5 months ago by gk

Keywords: TorBrowserTeam201905R added; TorBrowserTeam201904 removed

comment:6 Changed 5 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good to me. Let's see whether we are squashing #29982 here as well. Cherry-picked to tor-browser-60.6.1esr-8.5-1 as commit 7a0a10b8ff98ebfc53fa46fb3223af0f64a97964.

Note: See TracTickets for help on using tickets.