Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#3027 closed defect (invalid)

Possible problem after Win7x64 updates of 4/27/11

Reported by: bylund Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have used Tor (latest version) without problems, but after the Windows Update batch of updates of 4/27 I get a very annoying error: unable to apply settings, failed to bind one of the listener posts.

I've been through the settings, restarted my computer, installed the new alpha version, restarted the computer, then uninstalled, restarted, and reinstalled the stable version. Still same problem. So I'm guessing this has to do with the Win updates; here's a list of what was installed: KB2515325, KB2522422, KB2492386, KB982018, KB2506928.

Child Tickets

Attachments (2)

VidaliaLog-04.28.2011.txt (4.2 KB) - added by bylund 8 years ago.
Vidalia log of error
errmsg.PNG (24.0 KB) - added by bylund 8 years ago.
Error message (Vidalia)

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by bylund

Attachment: VidaliaLog-04.28.2011.txt added

Vidalia log of error

Changed 8 years ago by bylund

Attachment: errmsg.PNG added

Error message (Vidalia)

comment:1 Changed 8 years ago by bylund

Allow me to add that the error is only with relaying. I have no other problem using Tor.

comment:2 Changed 8 years ago by nickm

That looks like something else is already listening on port 443 and/or preventing Tor from doing so. Is there a webserver or another Tor instance or something running?

comment:3 Changed 8 years ago by nickm

Milestone: Tor: unspecified

comment:4 Changed 8 years ago by bylund

nickm: There is no other instance of Tor running. I've checked all processes. Also, the same error appears when I restart the computer.

The settings have not been changed - and it all worked before the Windows Updates.

comment:5 Changed 8 years ago by Sebastian

Status: newneeds_information

Hey, are you still experiencing the issue? We still don't know what it could be, but maybe you've noticed something in the meantime?

comment:6 Changed 8 years ago by bylund

Still experiencing it. I can't seem to get around it. The progress bar stops at around 10%, and that's when I get the error message asking me to stop or retry. If I retry, then nothing happens. It is just stuck there. 

comment:7 in reply to:  6 Changed 8 years ago by bylund

Sorry, that was meant for another thread. I don't have this particular problem anymore.

Replying to bylund:

Still experiencing it. I can't seem to get around it. The progress bar stops at around 10%, and that's when I get the error message asking me to stop or retry. If I retry, then nothing happens. It is just stuck there.

comment:8 Changed 8 years ago by rransom

Resolution: invalid
Status: needs_informationclosed

comment:9 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:10 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.