Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#30314 closed defect (not a bug)

Relay became Guard with less than 2 weeks of existence

Reported by: crimson_king Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The following relay gained the Guard flag before it was 2 weeks old:
https://metrics.torproject.org/rs.html#details/00DC112F7D4606D7E0E4B378D050490811BB20E5 (icarambva)

This may indicate a flaw in the judgement of Directory Authorities, as one of the requirements for becoming a Guard, besides being fast, is to have good uptime over many weeks.

Note: As of this moment, it has lost the flag.

Child Tickets

Change History (5)

comment:1 Changed 6 months ago by arma

Component: - Select a componentCore Tor/Tor

comment:2 Changed 6 months ago by arma

A relay can conceivably get the guard flag as quickly as 8 days after it first appears:

#define TIME_KNOWN_TO_GUARANTEE_FAMILIAR (8*24*60*60)

Is this your relay?

The atlas page is not really helpful at showing us what you're hoping we'll see.

comment:3 Changed 6 months ago by crimson_king

Thank you for that clarification. I believe this ticket can be closed now.

After re-reading https://blog.torproject.org/lifecycle-new-relay, I realized the uptime requirement for a relay to become a Guard isn't the only thing helping to keep it from being used maliciously.

It's not my relay.

comment:4 Changed 6 months ago by gaba

Resolution: not a bug
Status: newclosed

Thanks crimson_king!

comment:5 Changed 6 months ago by cypherpunks

guard probability 0%!

Note: See TracTickets for help on using tickets.