Opened 6 months ago

Closed 6 months ago

Last modified 5 months ago

#30331 closed defect (duplicate)

obfs4_bridgeline.txt file should contain complete bridge line

Reported by: cohosh Owned by:
Priority: Medium Milestone:
Component: Circumvention/Pluggable transport Version:
Severity: Normal Keywords: obfs4, bridge, anticensorship-roadmap-can
Cc: cohosh, phw Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor19

Description

When setting up an obfs4 bridge, the user has to perform extra steps to fill in the missing values to construct the full bridge line from /var/lib/tor/pt_state/obfs4_bridgeline.txt.

Specifically in:
Bridge obfs4 <IP ADDRESS>:<PORT> <FINGERPRINT> cert=<CERTIFICATE> iat-mode=0
only cert is populated automatically

Child Tickets

Change History (8)

comment:1 Changed 6 months ago by arma

Thanks! I agree this is an important thing to do for usability for bridge operators.

I would guess the hard part here might be that obfs4 knows some of the info, and Tor knows others of it, and no side easily knows both.

So it seems like we should have one side send the other side what it needs, so some side knows everything.

comment:2 Changed 6 months ago by yawning

no side easily knows both.

The tor daemon, knows everything because it's what generates and uploads the descriptor.

comment:3 Changed 6 months ago by arma

I'm tempted to call this a Tor ticket then, and Tor should write the whole bridge line to a log entry, or to a state file, or some other smart place?

(I imagine some people will be nervous about the idea of putting it in the log file, "because what if the operator accidentally reveals it to somebody", but I think usability trumps risk here.)

comment:4 Changed 6 months ago by yawning

I'm tempted to call this a Tor ticket then

That's what I would propose. Instead of passing extra information (that's not needed for anything other than this ticket) to each PT provider, it makes more sense to me to do it at a place where all of the information already exists.

and Tor should write the whole bridge line to a log entry, or to a state file, or some other smart place?

Maybe follow the obfs4 model and write all of the bridge lines to $DATADIR/pt_state/bridgelines.txt perhaps.

comment:5 Changed 6 months ago by gaba

Keywords: anticensorship-roadmap-can added

comment:6 Changed 6 months ago by cohosh

Resolution: duplicate
Status: newclosed

Closing as a duplicate of #29128

comment:7 Changed 5 months ago by phw

Parent ID: #30471

comment:8 Changed 5 months ago by arma

Parent ID: #30471

removing parent so we don't confuse #30471 by looking like this task is done

Note: See TracTickets for help on using tickets.