Opened 4 months ago

Closed 3 months ago

#30387 closed defect (not a bug)

open 20 onion bookmarks in tabs. tails, tor browser, onion circuits

Reported by: anon52569 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.5.8
Severity: Normal Keywords: ddos tails open-all-in-tabs
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

An onion site under DDOS published 20 onion links. After trying them manually for a while, I put them all into a bookmark folder and selected open all in bookmarks, hoping to find one that would connect. This did work on occasion. Watching onion circuits showed unexpected behavior. A large number of circuits were being opened. Some showed four links. clicking on 4 link circuit almost always caused it to disappear. The guard node switched to a new one on new circuits after a while. After this, all onion sites became unreachable, with many circuits opening and failing when trying a single not overloaded site. Restarting tails was required to reach regular onion sites.

I didn't intend to DOS the network myself, but it looks like that was the result. Perhaps this should be rate limited at the source.

Also, if I hadn't had onion circuits window open, I wouldn't have realized that something was wrong in my tor client. Some of the reported unavailable sites could be due to the user's tor client in a similar state.

Child Tickets

Attachments (1)

nightmare.html.base64 (3.6 KB) - added by anon52569 4 months ago.
base64 of importable bookmarks folder

Download all attachments as: .zip

Change History (2)

Changed 4 months ago by anon52569

Attachment: nightmare.html.base64 added

base64 of importable bookmarks folder

comment:1 Changed 3 months ago by dgoulet

Resolution: not a bug
Status: newclosed

This won't affect the network much. However, we are exploring rate-limiting options in #15516.

Note: See TracTickets for help on using tickets.