Opened 7 months ago

Closed 7 months ago

#30393 closed defect (duplicate)

Firefox 66.0.3 disables NoScript in Win TORBrowser 8.08 x64

Reported by: jhibbard Owned by: tbb-team
Priority: Immediate Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords: NoScript Disabled
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This started when I updated whatever the current version of FireFox 66.0.3 (x64) for Windows. Please see Ticket 1548973 at mozilla.org.
Upon update, reboot and starting 66.0.3, it reports that some addons have been disabled. Upon investigation, ALL addons have been disabled. In addition, the Addon Manager will not load any previously installed addon and reports that there is a connection issue.
Upon even more investigation, if you right click the "Add to Firefox" and choose open in New Tab (or New Window), an error message stating that Firefox has blocked the install request of the addon.
This situation even survives an uninstall of 66.0.3 -and- both a fresh install of 66.0.3 and a fresh install of 65.
It appears that there is also some relationship between any addon installed before the update/install of FireFox. Any new addon will install. By "new" I mean any addon that had not previously beeen installed, installs without issue.

So, here's how this has anything to do with TORBrowser. Somewhere in the process described above, I checked to see if TORBrowser was effected. And, it was (see attachment). I cannot say at this point that 8.08 was running or not during any part of the process described above. However, I did delete the entire sub directory for 8.08, reboot and reinstall 8.08. The attachment was created after this fresh install.

Child Tickets

Attachments (1)

Add-on disabled 2019-05-04_102842.png (31.2 KB) - added by jhibbard 7 months ago.

Download all attachments as: .zip

Change History (2)

Changed 7 months ago by jhibbard

comment:1 Changed 7 months ago by boklm

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team
Resolution: duplicate
Status: newclosed
Version: Tor: unspecified

This is a duplicate of #30388.

Note: See TracTickets for help on using tickets.