Opened 7 months ago

Closed 2 months ago

Last modified 9 days ago

#30460 closed defect (fixed)

Update TOPL Project to Use Android Toolchain (Firefox 68)

Reported by: sisbell Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, ff68-esr, tbb-9.0-must-alpha, TorBrowserTeam201910, BugSmashFund
Cc: boklm, sisbell, gk Actual Points:
Parent ID: #30324 Points: 1
Reviewer: Sponsor:

Description

Update TOPL Project to use the new android toolchain. This will include updating gradle dependencies and changes to the api versions.

Child Tickets

Change History (34)

comment:1 Changed 6 months ago by gk

Keywords: TorBrowserTeam201906 added; TorBrowserTeam201905 removed

Moving tickets to June

comment:2 Changed 5 months ago by gk

Keywords: TorBrowserTeam201907 added; TorBrowserTeam201906 removed

Moving tickets to July

comment:4 Changed 5 months ago by sisbell

Cc: gk added

comment:5 Changed 5 months ago by gk

Keywords: TorBrowserTeam201907R added; TorBrowserTeam201907 removed

comment:6 Changed 5 months ago by cypherpunks

+ buildToolsVersion "27.0.3"
Making such patches means you're doing something really wrong (Mozilla too).
Docs say "your project automatically uses a default version of the build tools that the plugin specifies", but even 3.1.0 knows it's not 27.0.3, because you need 28.0.3 to "add support for building with API level 28".

comment:7 Changed 5 months ago by gk

Keywords: tbb-9.0-must-nightly added

Starting with 9.0 keywords

comment:8 Changed 4 months ago by gk

Keywords: TorBrowserTeam201908R added; TorBrowserTeam201907R removed

No July any longer.

comment:9 Changed 4 months ago by pili

Sponsor: Sponsor44-can

Adding Sponsor 44 to ESR68 tickets

comment:10 Changed 4 months ago by gk

Keywords: TorBrowserTeam201908 added; TorBrowserTeam201908R removed
Status: needs_reviewneeds_revision

Quoting from #30461:

 2) I doubt we still need export GRADLE_MAVEN_REPO="file://$gradle_repo" as the patches relying on that are gone?

3) How do I re-create the dependencies list? I tried now for a while but still failed. Please update the how-to-create-gradle-dependencies-list.txt so I can verify your work.

(There is no 1) here. :) )

You probably don't need to address 3) here if you do address it in #30461 already.

comment:12 Changed 4 months ago by sisbell

Status: needs_revisionneeds_review

comment:13 Changed 4 months ago by gk

Keywords: TorBrowserTeam201908R added; TorBrowserTeam201908 removed

comment:14 Changed 4 months ago by gk

Looks mostly good. I still need to verify the dependencies list which is blocked by #31568.

comment:15 Changed 3 months ago by gk

Keywords: tbb-9.0-must-alpha added; tbb-9.0-must-nightly removed

Move must-nightly items to must-alpha ones.

comment:16 Changed 3 months ago by gk

Keywords: TorBrowserTeam201909 added

Moving must-alpha tickets to September.

comment:17 Changed 3 months ago by gk

Moving tickets to September

comment:18 Changed 3 months ago by gk

Keywords: TorBrowserTeam201909R added; TorBrowserTeam201908R removed

No August anymore.

comment:19 in reply to:  14 Changed 3 months ago by gk

Replying to gk:

Looks mostly good. I still need to verify the dependencies list which is blocked by #31568.

One thing to note here is that the dependencies list is not sorted (it is for the tor-android-service project, though). I think we should fix that in a follow-up commit.

comment:20 Changed 3 months ago by pili

Points: 1

comment:21 Changed 2 months ago by pili

Keywords: TorBrowserTeam201910R added; TorBrowserTeam201909R removed

We're now in October, moving September outstanding reviews to October

comment:22 Changed 2 months ago by pili

Keywords: TorBrowserTeam201909 removed

comment:23 Changed 2 months ago by cypherpunks

Thanks for helping gk :)

comment:24 Changed 2 months ago by sisbell

Resolution: fixed
Status: needs_reviewclosed

Closing this one out since the issue is already merged into master. Opened #31979 to track the dependency sorting issue

comment:25 in reply to:  24 Changed 2 months ago by gk

Resolution: fixed
Status: closedreopened

Replying to sisbell:

Closing this one out since the issue is already merged into master. Opened #31979 to track the dependency sorting issue

There are a bunch of issues already merged to master but not closed yet because I am still waiting of some dependencies finished first to double-check whether the work in those tickets is correct. In this case #31568 is still unfixed and I am not sure whether my suggested fix is working (see e.g. your comment:16:ticket:31568). So, I am not really sure whether the dependencies you added in the TOPL update check are correct. Thus, let's leave this ticket open until we are sure wrt #31568.

comment:26 Changed 2 months ago by gk

Oh and I was not happy to commit the changes but leaving the bug open. However, we needed to get our alpha build going...

comment:27 Changed 2 months ago by sisbell

Are we good to close this issue after fixing #31568 and #31979?

comment:28 Changed 2 months ago by gk

Keywords: TorBrowserTeam201910 added; TorBrowserTeam201910R removed
Status: reopenedneeds_revision

It seems to me the gradle.patch is not needed? Please remove it. We only provide 27.0.3 in our toolchain, so there is no danger of using the wrong one instead.

comment:29 in reply to:  28 ; Changed 2 months ago by sisbell

We still need this patch. Otherwise when we generate the gradle dependencies list it will contain later versions of the gradle plugin and tools: 3.1.4 (instead of 3.1.0, which is the one we want).

Replying to gk:

It seems to me the gradle.patch is not needed? Please remove it. We only provide 27.0.3 in our toolchain, so there is no danger of using the wrong one instead.

comment:30 in reply to:  29 Changed 2 months ago by gk

Replying to sisbell:

We still need this patch. Otherwise when we generate the gradle dependencies list it will contain later versions of the gradle plugin and tools: 3.1.4 (instead of 3.1.0, which is the one we want).

I see. Then please add a comment in the TOPL config explaining that, so we know why the patch is there.

Replying to gk:

It seems to me the gradle.patch is not needed? Please remove it. We only provide 27.0.3 in our toolchain, so there is no danger of using the wrong one instead.

comment:31 Changed 2 months ago by sisbell

Status: needs_revisionneeds_review

comment:32 Changed 2 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

I actually meant config as the patch gets added there but I guess adding the comment in the build file is okay, too. Looks good and cherry-picked onto master with commit 7fc43b5e228232caede87b571777e4a0448780d4.

comment:33 Changed 9 days ago by pili

Keywords: BugSmashFund added

BugSmashFund can be used for the ESR work done so far

comment:34 Changed 9 days ago by pili

Sponsor: Sponsor44-can

Sponsor 44 only covered PM and Team Lead work

Note: See TracTickets for help on using tickets.