Opened 2 weeks ago

Closed 11 days ago

#30481 closed defect (not a bug)

./TorBrowser/Tor/libstdc++.so.6: version `GLIBCXX_3.4.22' not found

Reported by: akwala Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

OS: Kubuntu 18.04

The following happened when I tried to launch the browser for the first time after installing it.

$ ./start-tor-browser.desktop --debug
Launching './Browser/start-tor-browser --detach --debug'...
XPCOMGlueLoad error for file /path/to/tor-browser_en-US/Browser/libxul.so:
./TorBrowser/Tor/libstdc++.so.6: version `GLIBCXX_3.4.22' not found (required by /path/to/tor-browser_en-US/Browser/libxul.so)
Couldn't load XPCOM.

#13359 is similar but this time it finds the bundled libstdc++.

Child Tickets

Attachments (1)

tbb_version.json (82 bytes) - added by akwala 13 days ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 2 weeks ago by gk

Cc: boklm added
Status: newneeds_information
Version: Tor: 0.3.5.8

Where did you get Tor Browser from and what version is that? What do you mean with " #13359 is similar but this time it finds the bundled libstdc++."?

Changed 13 days ago by akwala

Attachment: tbb_version.json added

comment:2 Changed 13 days ago by akwala

Where did you get Tor Browser from and what version is that?

I downloaded it from https://www.torproject.org/download/ (v. 8.0.9) -- see attached file /path/to/tor-browser_en-US/Browser/tbb_version.json. After verifying the downloaded *.tar.xz file with the corresponding *.asc signature, also downloaded from the same page, I extracted the contents of the *.tar.xz file and ran

./start-tor-browser.desktop --register-app

in /path/to/tor-browser_en-US/. This created the file start-tor-browser.desktop in ~/.local/share/applications. The browser did not launch when I tried to launch it from the desktop launcher. This is when I tried

./start-tor-browser.desktop --debug

in /path/to/tor-browser_en-US/, the result of which is in the description of this issue report.


What do you mean with " #13359 is similar but this time it finds the bundled libstdc++."?

The description of #13359 says

... it fails to restart because the bundled copy of libstdc++.so.6 is not found ...

and the error message shows that it's using /usr/lib/x86_64-linux-gnu/libstdc++.so.6, which is a system location.

In my case, the error message shows that ./TorBrowser/Tor/libstdc++.so.6 is being used, which is the location of the bundled copy of libstdc++.so.6, and yet it complains that the required version GLIBCXX_3.4.22 is not found.

Last edited 13 days ago by akwala (previous) (diff)

comment:3 in reply to:  2 ; Changed 11 days ago by boklm

Replying to akwala:

Where did you get Tor Browser from and what version is that?

I downloaded it from https://www.torproject.org/download/ (v. 8.0.9) -- see attached file /path/to/tor-browser_en-US/Browser/tbb_version.json. After verifying the downloaded *.tar.xz file with the corresponding *.asc signature, also downloaded from the same page, I extracted the contents of the *.tar.xz file and ran

The file ./TorBrowser/Tor/libstdc++.so.6 should not exist in Tor Browser 8.0.9 (it has been moved to TorBrowser/Tor/libstdc++/libstdc++.so.6).

Did you install 8.0.9 in an empty directory, or over an older installation of Tor Browser?

comment:4 in reply to:  3 ; Changed 11 days ago by akwala

Replying to boklm:

The file ./TorBrowser/Tor/libstdc++.so.6 should not exist in Tor Browser 8.0.9 (it has been moved to TorBrowser/Tor/libstdc++/libstdc++.so.6).

Did you install 8.0.9 in an empty directory, or over an older installation of Tor Browser?

That's it. I just installed it in a fresh directory and the browser launched as expected.

This issue is resolved. However, it's not standard procedure to install/extract in a new directory.

comment:5 in reply to:  4 Changed 11 days ago by gk

Resolution: not a bug
Status: needs_informationclosed

Replying to akwala:

Replying to boklm:

The file ./TorBrowser/Tor/libstdc++.so.6 should not exist in Tor Browser 8.0.9 (it has been moved to TorBrowser/Tor/libstdc++/libstdc++.so.6).

Did you install 8.0.9 in an empty directory, or over an older installation of Tor Browser?

That's it. I just installed it in a fresh directory and the browser launched as expected.

This issue is resolved. However, it's not standard procedure to install/extract in a new directory.

Yes, I agree. On the other hand it's causing undefined behavior or bugs if you just overwrite older Tor Browsers with newer ones. The recommended way is to use the built-in auto-updater as it takes care of removing old and not longer needed files as well and adjusts all other things, too, that are needed for a successful Tor Browser launch.

Note: See TracTickets for help on using tickets.