Opened 7 months ago

Closed 7 months ago

#30484 closed defect (fixed)

Upgrade To Android Plugin 3.4.0

Reported by: sisbell Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, tor-android-service, TorBrowserTeam201905
Cc: gk, sysrqb Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Use the latest version of Android Plugin 3.4.0 in tor-android-service. We also need to upgrade gradle to 5.x to support this version of the plugin.

This upgrade is to allow developers using tor-android-service to continue to use the latest features and versions of Android Studio. The plugin version will be patched to older versions for tor-browser-builds.

Child Tickets

Change History (5)

comment:1 Changed 7 months ago by sisbell

Status: newneeds_review

Fixed in branch 0512: https://github.com/sisbell/tor-android-service/commits/0512

comment:2 Changed 7 months ago by nobell

I wish it were the default for esr68.

comment:3 Changed 7 months ago by gk

Keywords: TorBrowserTeam201905 added
Status: needs_reviewneeds_information

What's the reason for suddenly including times like

+#Sat Apr 27 12:57:35 PDT 2019

?

Otherwise this looks good to me.

comment:4 in reply to:  3 Changed 7 months ago by sisbell

Replying to gk:

What's the reason for suddenly including times like

+#Sat Apr 27 12:57:35 PDT 2019

?

When we generate a new wrapper through the command line, it will put in the date the wrapper was generated.

./gradlew wrapper --gradle-version=5.1.1 --distribution-type=bin

Otherwise this looks good to me.

comment:5 Changed 7 months ago by gk

Resolution: fixed
Status: needs_informationclosed

Okay, fixed in commit c464f6cc0fb78fb99dd01fba3df9843fb929023c on master.

Note: See TracTickets for help on using tickets.