Opened 4 months ago

Closed 4 months ago

#30520 closed defect (not a bug)

Onion Service (v2) hosting Tor instance reporting under high load: Failed to find node for hop #1 of our path. Discarding this circuit.

Reported by: s7r Owned by:
Priority: Medium Milestone: Tor: 0.4.1.x-final
Component: Core Tor/Tor Version: Tor: 0.4.0.1-alpha
Severity: Normal Keywords: tor-hs tor-dos
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor27-can

Description (last modified by s7r)

An onion hosting Tor instance is reporting strange stuff for the last 3 days. The server was attacked (DOS / SYN Flood last days), so maybe this could have triggered some network connection changes but the connection remained active / online. The torrc is very simple:

SocksPort 127.0.0.1:9050
ControlPort 0
HiddenServiceDir /var/lib/tor/tor_hs
HiddenServiceVersion 2
HiddenServicePort <port> 127.0.0.1:<port>

1)

May 12 11:16:08.000 [notice] Your network connection speed appears to have changed. Resetting timeout to 60s after 18 timeouts and 362 buildtimes.
May 12 22:20:32.000 [notice] No circuits are opened. Relaxed timeout for circuit 398807 (a Hidden service: Connecting to rendezvous point 4-hop circuit in state doing handshakes with channel state open) to 106324ms. However, it appears the circuit has timed out anyway. [16 similar message(s) suppressed in last 3600 seconds]

2)

May 13 11:05:36.000 [notice] No circuits are opened. Relaxed timeout for circuit 399137 (a General-purpose client 3-hop circuit in state waiting to see how other guards perform with channel state open) to 106324ms. However, it appears the circuit has timed out anyway. [27 similar message(s) suppressed in last 3600 seconds]

3)

May 14 21:27:36.000 [warn] Failed to find node for hop #1 of our path. Discarding this circuit.
May 14 21:27:36.000 [notice] Our circuit 0 (id: 400112) died due to an invalid selected path, purpose General-purpose client. This may be a torrc configuration issue, or a bug. [8 similar message(s) suppressed in last 3600 seconds]

I wish I could reproduce the last one. Could this be a bug that occurs when our primary #1 Guard is in consensus but not reachable just for a certain machine / IP?

Child Tickets

Change History (3)

comment:1 Changed 4 months ago by s7r

Description: modified (diff)

comment:2 Changed 4 months ago by asn

Keywords: tor-dos added
Milestone: Tor: 0.4.1.x-final
Sponsor: Sponsor27-can

comment:3 Changed 4 months ago by dgoulet

Resolution: not a bug
Status: newclosed

This is often due to a service not being able to reach its Guard... and thus everything circuit construction related stops...

Not much can be done apart from letting tor pick a new Guard or deleting your state file and restarting Tor...

External factors are making the service not being able to join the network :S.

Note: See TracTickets for help on using tickets.