Opened 6 months ago

Closed 6 months ago

#30533 closed defect (not a bug)

Bandwidth Unmeasured in Testing Tor Network

Reported by: TBD.Chen Owned by:
Priority: Medium Milestone:
Component: Core Tor/DirAuth Version: Tor: 0.3.3.8
Severity: Normal Keywords: Bandwiidth, Testing Tor Network
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have run the Testing Tor Network based on docker, however, the bandwidth of relays in consensus is 0, and they are labeled as unmeasured.
like

r tor21 AXeRGqg59zZ0JOyocxlonwk84Qg zv7cbbO1TcuYfwhzA/VjeE/u9UY 2019-05-18 15:49:03 172.25.0.121 5000 0
s Exit Fast Running V2Dir Valid
v Tor 0.3.5.7
pr Cons=1-2 Desc=1-2 DirCache=1-2 HSDir=1-2 HSIntro=3-4 HSRend=1-2 Link=1-5 LinkAuth=1,3 Microdesc=1-2 Relay=1-2
w Bandwidth=0 Unmeasured=1 (The bandwidth is labeled as unmeasured)
p reject 25,119,135-139,445,563,1214,4661-4666,6346-6429,6699,6881-6999

The torrc file of my authority server is listed as following:

Log info file /root/log/info.log
DisableDebuggerAttachment 0

SocksPort 0
OrPort 5000
Address 172.25.0.10
DirPort 7000

AuthoritativeDirectory 1
V3AuthoritativeDirectory 1
ContactInfo auth@test.test
ExitPolicy reject *:*


ServerDNSAllowBrokenConfig 1
DirAllowPrivateAddresses 1
EnforceDistinctSubnets 0
AssumeReachable 1
AuthDirMaxServersPerAddr 0
AuthDirMaxServersPerAuthAddr 0
ClientDNSRejectInternalAddresses 0
ClientRejectInternalAddresses 0
CountPrivateBandwidth 1
ExitPolicyRejectPrivate 0
ExtendAllowPrivateAddresses 1
V3AuthVotingInterval 5 minutes
V3AuthVoteDelay 20 seconds
V3AuthDistDelay 20 seconds
MinUptimeHidServDirectoryV2 0 seconds
TestingV3AuthInitialVotingInterval 5 minutes
TestingV3AuthInitialVoteDelay 20 seconds
TestingV3AuthInitialDistDelay 20 seconds
TestingAuthDirTimeToLearnReachability 0 minutes
TestingEstimatedDescriptorPropagationTime 0 minutes
TestingClientMaxIntervalWithoutRequest 5 seconds
TestingDirConnectionMaxStall 30 seconds
TestingEnableConnBwEvent 1
TestingEnableCellStatsEvent 1

The version of tor is 0.3.3.8

Child Tickets

Change History (3)

comment:1 Changed 6 months ago by nickm

First off, 0.3.3.8 isn't supported. If it turns out that the problem is related to the version, we van't help much.

Second, a question: are you running any bandwidth authorities on this network? If not, bandwidth won't get measured.

comment:2 in reply to:  1 Changed 6 months ago by TBD.Chen

Replying to nickm:
Thank you, I think I really do not run a bandwidth authority. I just run a directory authority server in my testing network. Could you give a link to show how to run a bandwidth authority? It seems that the manual document (https://2019.www.torproject.org/docs/tor-manual-dev.html.en) is not cover the bandwidth authority.

First off, 0.3.3.8 isn't supported. If it turns out that the problem is related to the version, we van't help much.

Second, a question: are you running any bandwidth authorities on this network? If not, bandwidth won't get measured.

comment:3 Changed 6 months ago by teor

Resolution: not a bug
Status: newclosed

The bandwidth authority is a separate program that provides data to a Tor directory authority.

There are two implementations of the bandwidth authority, the most recent and easiest to use is sbws.

The install and deployment instructions are here:
https://sbws.readthedocs.io/en/master/

You will need to configure the bandwidth authority tor client with the details of your test network. Otherwise it will run on the public tor network.

If you find any bugs, please report them in another ticket. Thanks!

Note: See TracTickets for help on using tickets.