Opened 2 months ago

Closed 2 months ago

#30536 closed defect (fixed)

Update go to 1.12.5

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, ff68-esr, TorBrowserTeam201905R
Cc: dcf, cohosh Actual Points:
Parent ID: #30491 Points:
Reviewer: Sponsor:

Description

We should update to the go 1.12 series to be able to move our macOS builds to Debian Stretch.

Child Tickets

Change History (4)

comment:1 Changed 2 months ago by gk

Keywords: TorBrowserTeam201905R added; TorBrowserTeam201905 removed
Status: newneeds_review

bug_30536 (https://gitweb.torproject.org/user/gk/tor-browser-build.git/commit/?h=bug_30536&id=4674d8a76619eb05562d81b3f77756cce1ebfe9d) has the fix. Builds are still reproducible and I encountered no broken builds when building for the various platforms. I double-checked that the PTs on Windows and Linux are still working after the Go update.

Last edited 2 months ago by gk (previous) (diff)

comment:2 Changed 2 months ago by dcf

It looks fine to me if it's okay with cohosh.

comment:3 Changed 2 months ago by cohosh

Yep, works for me.

comment:4 Changed 2 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks. Merged to master (commit 32f6ddd0869e3e24136218b8158c605263dc730e).

Note: See TracTickets for help on using tickets.