Opened 7 months ago

Closed 3 months ago

Last modified 3 months ago

#30538 closed defect (fixed)

Unable to comment on The Independent Newspaper

Reported by: mwolfe Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability-website
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I used to be able to comment on The Independent newspaper using Tor,
www dot independent dot co dot uk, but now, when I try to comment, the comment button is disabled. I don't know if it's Noscript or something else, I just know the button is disabled if I use Tor.

Also, Tor is no longer able to reach gocomics dot com for some reason. I suppose they might have gone to an anti-spam package that blocks all Tor exit nodes, but there is no 'Spam. Blocked' error message, just 'unable to connect'

Child Tickets

Attachments (2)

independenterrorlog.zip (30.2 KB) - added by mwolfe 4 months ago.
partial error log when I try to log in to comment on Independent
Console.rtf.zip (8.5 KB) - added by mwolfe 4 months ago.
more complete console log

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 months ago by gk

Component: - Select a componentApplications/Tor Browser
Keywords: tbb-usability-website added
Owner: set to tbb-team
Status: newneeds_information

Gocomics works for me if I switch the circuits for a bit. It does indeed seem to be the case that they don't like some exit nodes.

What do I have to do to reproduce the comment issue?

comment:2 Changed 7 months ago by mwolfe

This isn't about gocomics, it's about The Independent newspaper, www dot independent dot co dot uk
If one has an account and tries to comment, one cannot. Before, there was a 'Join the discussion' button, but now it's disabled (and so greyed and hard to see). If I log in, I can upvote other comments, but cannot comment or reply. Disabling NoScript does not allow comments.

comment:3 in reply to:  1 ; Changed 7 months ago by mwolfe

Replying to gk:

Gocomics works for me if I switch the circuits for a bit. It does indeed seem to be the case that they don't like some exit nodes.

What do I have to do to reproduce the comment issue?

This isn't about gocomics, it's about The Independent newspaper, www dot independent dot co dot uk
If one has an account and tries to comment, one cannot. Before, there was a 'Join the discussion' button, but now it's disabled (and so greyed and hard to see). If I log in, I can upvote other comments, but cannot comment or reply. Disabling NoScript does not allow comments.

comment:4 Changed 7 months ago by gk

Status: needs_informationnew

comment:5 in reply to:  3 ; Changed 5 months ago by mwolfe

Replying to mwolfe:

Replying to gk:

Gocomics works for me if I switch the circuits for a bit. It does indeed seem to be the case that they don't like some exit nodes.

What do I have to do to reproduce the comment issue?

This isn't about gocomics, it's about The Independent newspaper, www dot independent dot co dot uk

The comment box on the Independent Newspaper website says,
<textarea required="" data-amp-bind-disabled="!userState.hasNickname" i-amphtml-binding="" placeholder="Write a reply..." name="comment" class="comment-field logged-in" disabled=""></textarea>

so it's disabled. Not clear why Tor stops the Independent from enabling the comment field when one logs in.

Changed 4 months ago by mwolfe

Attachment: independenterrorlog.zip added

partial error log when I try to log in to comment on Independent

Changed 4 months ago by mwolfe

Attachment: Console.rtf.zip added

more complete console log

comment:6 in reply to:  5 Changed 4 months ago by mwolfe

I really miss being able to comment and reply to the Independent articles. Any chance this can be fixed? Any work-arounds?

Replying to mwolfe:

Replying to mwolfe:

Replying to gk:

Gocomics works for me if I switch the circuits for a bit. It does indeed seem to be the case that they don't like some exit nodes.

comment:7 Changed 3 months ago by mwolfe

Tor 9.0a6 is able to comment on the Independent website! Fixed at last!

comment:8 in reply to:  7 Changed 3 months ago by cypherpunks

Replying to mwolfe:

Tor 9.0a6 is able to comment on the Independent website! Fixed at last!

Thanks to the move to 68 ESR. This seems to have been a Firefox issue.

comment:9 Changed 3 months ago by pili

Resolution: fixed
Status: newclosed

Glad to hear this is now fixed.

comment:10 Changed 3 months ago by cypherpunks

ff68-esr-will-have then.

Note: See TracTickets for help on using tickets.