Opened 3 months ago

Closed 3 months ago

#30587 closed defect (duplicate)

Saving a file in Tor Browser resets Gnome Files (Naultilus) sort-directoires-first setting

Reported by: califuture Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have Gnome Files' Preferences set to *not* "Sort folder before files".

When I save a file using Tor Browser it resets that setting.

Steps to reproduce
In Gnome Files' Preferences un-tick the "Sort folder before files" option.
Launch Tor Browser and save a file using it (e.g. an image from Wikipedia)

You can see the change happening live if you keep the Gnome Files' Preferences dialogue open. The box gets re-ticked.

You can see similar using dconf Editor if you open it on this /org/gtk/settings/file-chooser/sort-directories-first

This bug might be specific to Wayland?

Strictly this might not be Gnome Files but that's where the issue becomes apparent (it actually seems to be something called gtk file chooser?)

Ubuntu 19.04
Wayland
Tor Browser 8.5 (it also happened with the previous version)
Gnome Files 3.32.0-stable

Child Tickets

Change History (2)

comment:1 Changed 3 months ago by califuture

I forgot to add that regular Firefox (66.0.5) doesn't have this issue.

comment:2 Changed 3 months ago by gk

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team
Resolution: duplicate
Status: newclosed

Duplicate of #27903. See there for a workaround.

Note: See TracTickets for help on using tickets.