Opened 5 months ago

Closed 5 months ago

#30622 closed defect (duplicate)

Tor Browser UA and JS UA inconstent

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

HTTP_USER_AGENT

Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0

Navigator.userAgent

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Child Tickets

Change History (2)

comment:1 Changed 5 months ago by Thorin

Not a duplicate of #28290 (my bad). The difference is the exclusion of the architecture in the header when RFP is on, in which case it doesn't match the spec.

FF+RFP=off

  • Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0 (both)

FF+RFP=on

  • Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0 (header)
  • Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 (js)

I think this is better sorted upstream to tweak RFP to match the spec. The architecture being put back in shouldn't add any entropy: since we only return Windows or Android: just add the navigator oscpu string in full rather than truncate it

FYI: There's a discussion going on about limiting architecture: not to do with RFP though, but may be relevant. - here it is:

Last edited 5 months ago by Thorin (previous) (diff)

comment:2 Changed 5 months ago by gk

Resolution: duplicate
Status: newclosed

I actually still think it's a dupe of #28290.

Note: See TracTickets for help on using tickets.