Opened 4 weeks ago

Closed 3 weeks ago

#30647 closed defect (duplicate)

Letterboxing and Scrollbars Dimensions

Reported by: edgewall Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-fingerprinting-resolution
Cc: tom Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Letterboxing's reason of existence is to improve the users' privacy by reducing yet another fingerprinting bit. But the solution isn't perfect - there are many operating systems and window managers, and countless themes. And every one of them can have different scrollbar dimensions - which helps to fingerprint the user.

For example, in a page with a vertical scrollbar my window widths is being reported as 984px instead of 1000px with Tor Browser's "content window dimensions rounding" (#14429), or 1184px instead of 1200px with FF67's letterboxing.

Would it be possible to maybe move the scrollbars (both vertical and horizontal) out of the "letterbox"?

Child Tickets

Change History (6)

comment:1 Changed 4 weeks ago by Thorin

You can still get scrollbars without letterboxing, which is applied to the inner window not the viewport.

Duplicate of #22137

comment:2 Changed 4 weeks ago by gk

Cc: tom added
Status: newneeds_information

Tom, what do you think?

comment:3 Changed 4 weeks ago by Thorin

Where would the vertical/horizontal scrollbars go when the inner window width/height respectively matches the rounding? Scrollbar widths can also be gained from within elements, so this is not the solution IMO :)

comment:4 Changed 4 weeks ago by tom

ACK, in my todo list

comment:5 Changed 3 weeks ago by gk

Keywords: tbb-fingerprinting-resolution added
Status: needs_informationnew

comment:6 Changed 3 weeks ago by tom

Resolution: duplicate
Status: newclosed

I agree with Thorin. While in some situations, it would be nice to have the scrollbar outside the letterbox and regain those pixels; that doesn't work in many other situations.

I think the correct fix for this is #22137

Note: See TracTickets for help on using tickets.