Opened 3 months ago

Last modified 2 months ago

#30660 needs_information defect

Tor does not run while sandboxed

Reported by: Nanon Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The last two updates in a row have made it impossible to run TOR within a sandbox resulting in this error:

firefox.exe - DDL Initialization Failed

Initialization of the dynamic link library C:\program files\sandbox\SbieDll.dll failed. The process is terminating abnormally.

It does not matter what sandbox application used, the same error occurs.

Child Tickets

Change History (3)

comment:1 Changed 3 months ago by gk

Priority: Very HighMedium
Severity: CriticalNormal
Status: newneeds_information

What do you mean wit "last two updates"? Which versions did still work for you? (There are older ones at https://archive.torproject.org/tor-package-archive/torbrowser/ to test)

Does the same problem occur with a Firefox 60 ESR, which Tor Browser is built upon? (See: https://www.mozilla.org/en-US/firefox/organizations/all/)

comment:2 Changed 2 months ago by lior

I'm the one who posted the same sandboxing problem on the Tor blog. I first noticed a problem running the Tor Browser with Sandboxie when you released Tor Browser v. 8.0.9. At that time, I would get the same error messages reported in this ticket, but if I repeatedly exited and relaunched Tor, it would eventually run in the sandbox. It wasn't until I updated to v 8.5 that the Tor Browser would not run in the sandbox at all.

I downloaded Firefox ESR Portable v 60.7.0 (from portableapps.com) because I did not have time to install Firefox to test it with Sandboxie. This Firefox portable version does run in the sandbox without giving any error messages.

If it matters, I'm running Windows 10 Home Edition, Version 1803, OS Build 17134.765. Sandboxie is version 5.60.

comment:3 Changed 2 months ago by gk

Thanks for getting back to us, really appreciated. So, 8.0.9 does not have so many changes, they are mainly related to Mozilla's add-on desaster and I don't see how this could cause the problems you see. Could you double-check that 8.0.8 starts without any issues and 8.0.9 is indeed the first version that causes problems? Older bundles can be found at: https://archive.torproject.org/tor-package-archive/torbrowser/.

Note: See TracTickets for help on using tickets.