Opened 3 months ago

Closed 3 months ago

Last modified 2 months ago

#30679 closed defect (not a bug)

Ask Mozilla to support Web Extensions for its upcoming mobile browser

Reported by: cypherpunks Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser developers should ask Mozilla to support Web Extensions for its upcoming mobile browser base, Fenix. Tor Browser developers asking this would make them prioritize this more than if regular users ask.

There are open feature requests about this but they haven't given a single clear response on when they will support Web Extensions if ever.

This is very important for NoScript and HTTPS Everywhere to work on Tor Browser mobile when Fenix is deployed as Firefox.

Child Tickets

Change History (7)

comment:1 Changed 3 months ago by gk

Resolution: not a bug
Status: newclosed

Yes, that's planned. Some of us will be at the upcoming Mozilla All Hands meeting and we'll ask there.

comment:2 Changed 3 months ago by cypherpunks

Great. Please provide an update here if you are able to get a clear response from them.

comment:3 Changed 3 months ago by cypherpunks

Support for built-in WebExtensions has been added! The new Reader View feature component (in Fenix and Reference Browser) is built on top of this.

FWIW, technically it is available.

comment:4 Changed 3 months ago by cypherpunks

Those are internal Web Extensions. Completely different than regular Web Extensions which will require much more work to be done.

comment:5 Changed 2 months ago by cypherpunks

gk, were you able to get an answer about this from Mozilla?

comment:6 Changed 2 months ago by gk

Yes, we asked. We'll be able to bundle our WebExtensions.

comment:7 Changed 2 months ago by cypherpunks

Thanks gk.

If you can clarify, does that mean that Web Extensions will work on Fenix based Tor Browser just as they are now or will special changes need to be made to the Web Extensions for them to work properly on Fenix based Tor Browser?

Did they give you any timeline on when they estimate Web Extensions to be implemented in Fenix and when they expect to first deploy Fenix as Firefox?

Note: See TracTickets for help on using tickets.