Opened 11 days ago

Closed 7 days ago

Last modified 7 days ago

#30784 closed defect (not a bug)

Windows put its timeval definitions in winsock2.h

Reported by: teor Owned by: ahf
Priority: Medium Milestone: Tor: 0.4.1.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: windows, compilation-error
Cc: Actual Points: 0.1
Parent ID: Points: 0.5
Reviewer: Sponsor:

Description

See the pull request:
https://github.com/torproject/tor/pull/1085

We'll need to backport this change to 0.2.9, assuming we used winthreads back then.

I'm going to assign this one to ahf, because he has a local windows build.

Child Tickets

Change History (3)

comment:1 Changed 7 days ago by saurik

So, I'm the reason this ticket exists (having filed a pull request on GitHub), and I've now spent some more time trying to figure out why this would work for you but not for me; I had originally thought it was because I was using MinGW (and so tend to run into issues with subtle differences in header files), but when I saw your CI system was using MinGW I figured I should dig deeper... and I tracked it down to my toolchain setup (incorrectly) having hardcoded WIN32_LEAN_AND_MEAN, which meant that the #include you already have for <windows.h> wasn't sufficient, but it should have been, so I'm sorry: you can just close this ticket as invalid. (Again: sorry.)

comment:2 Changed 7 days ago by teor

Resolution: not a bug
Status: assignedclosed

No worries, thanks for helping us out!

comment:3 Changed 7 days ago by teor

Actual Points: 0.1
Keywords: 041-should 029-backport-maybe 034-backport 035-backport 040-backport removed
Note: See TracTickets for help on using tickets.