Opened 4 months ago

Closed 4 months ago

#30804 closed defect (fixed)

util/socketpair_ersatz test requires configured network

Reported by: nickm Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-tests, tor-ci, 041-should, asn-merge
Cc: Actual Points: .1
Parent ID: #30409 Points:
Reviewer: dgoulet Sponsor:

Description

When I use unshare -r -n ./src/test/test to try to reproduce #30409, I get this error:

util/socketpair_ersatz: [forking] 
  FAIL src/test/test_util.c:5402: assert(0 OP_EQ socketpair_result): 0 vs -101
  [socketpair_ersatz FAILED]

Child Tickets

Change History (5)

comment:1 Changed 4 months ago by nickm

Owner: changed from < default nickm to nickm

comment:2 Changed 4 months ago by nickm

Actual Points: .1

See branch bug30804 with PR at https://github.com/torproject/tor/pull/1088 .

I vote "no backport" on this, since it only occurs when running the tests with the network disabled.

comment:3 Changed 4 months ago by nickm

Status: assignedneeds_review

comment:4 Changed 4 months ago by dgoulet

Keywords: asn-merge added
Reviewer: dgoulet
Status: needs_reviewmerge_ready

LGTM. Agree with no backport.

comment:5 Changed 4 months ago by asn

Resolution: fixed
Status: merge_readyclosed

Merged to master. No backport.

Note: See TracTickets for help on using tickets.