Opened 6 weeks ago

Closed 6 weeks ago

#30822 closed defect (fixed)

Update git scripts to remove 0.3.4, include 0.4.1

Reported by: nickm Owned by: nickm
Priority: High Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: asn-merge, 041-should
Cc: Actual Points: .1
Parent ID: #30835 Points: .1
Reviewer: Sponsor:

Description

0.3.4 is now EOL; it should no longer be covered by our push-all/pull-all/merge-forward scripts.

0.4.1 is now a separate branch; it should new be covered by those scripts.

Child Tickets

Change History (7)

comment:1 Changed 6 weeks ago by nickm

Actual Points: .1
Status: assignedneeds_review

See branch ticket30822 with PR at https://github.com/torproject/tor/pull/1098

In addition to the minimal branch changes, I also updated the scripts so that you can override some of the settings from environment variables. This way I won't have to edit the scripts manually whenever they are updated.

comment:2 Changed 6 weeks ago by dgoulet

Keywords: asn-merge added
Status: needs_reviewmerge_ready

LGTM!

comment:3 Changed 6 weeks ago by teor

Parent ID: #30835

comment:4 Changed 6 weeks ago by teor

Keywords: 041-should added

comment:5 Changed 6 weeks ago by teor

I tested this change while doing some 0.3.5 backports.

comment:6 Changed 6 weeks ago by teor

(I also made some further changes in #30840, to get things working on macOS / my setup.)

comment:7 Changed 6 weeks ago by asn

Resolution: fixed
Status: merge_readyclosed

Merged!

Note: See TracTickets for help on using tickets.