Opened 4 months ago

Closed 4 months ago

#30875 closed defect (duplicate)

If you start Tor with UseBridges 1, no ClientTransportPlugin, and only obfs4 bridges, it should fail

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: cohosh, ahf Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor30-can

Description

If you start your Tor client with just this line:

usebridges 1

it will refuse to start, because you gave it no bridges:

Jun 13 00:06:48.337 [warn] Failed to parse/validate config: If you set UseBridges, you must specify at least one bridge.
Jun 13 00:06:48.337 [err] Reading config failed--see warnings above.

But if instead you start it with

usebridges 1
bridge obfs4 85.17.30.79:443 FC259A04A328A07FED1413E9FC6526530D9FD87A cert=RutxZlu8BtyP+y0NX7bAVD41+J/qXNhHUrKjFkRSdiBAhIHIQLhKQ2HxESAKZprn/lR3KA iat-mode=0

it will start up, trying to treat that bridge as a vanilla bridge:

Jun 13 00:10:23.164 [notice] Bootstrapped 0% (starting): Starting
Jun 13 00:10:23.278 [notice] Starting with guard context "bridges"
Jun 13 00:10:23.279 [notice] Delaying directory fetches: No running bridges
Jun 13 00:10:24.153 [notice] Bootstrapped 5% (conn): Connecting to a relay
Jun 13 00:10:24.247 [notice] Bootstrapped 10% (conn_done): Connected to a relay

That is, it's trying to connect to an ORPort on 85.17.30.79:443, presumably to fetch a bridge descriptor. Of course that isn't working because that's an obfs4 port.

Should Tor not count bridges for transports it doesn't have a ClientTransportPlugin line for, and if it ends up with no bridges that it knows how to use, refuse that configuration in the same way that it does now for no bridges?

Child Tickets

Change History (7)

comment:1 Changed 4 months ago by arma

(noticed after seeing a user in #tor do exactly this, and his Tor gave him no hints that things were never going to work)

comment:2 Changed 4 months ago by nickm

Milestone: Tor: unspecified

comment:3 Changed 4 months ago by teor

Cc: cohosh ahf added
Sponsor: Sponsor28-can

Is this something that the anti-censorship team wants to fix?

comment:4 Changed 4 months ago by gaba

Sponsor: Sponsor28-can

comment:5 Changed 4 months ago by dcf

Looks like a duplicate of #25528?

comment:6 Changed 4 months ago by gaba

Sponsor: Sponsor30-can

comment:7 Changed 4 months ago by gaba

Resolution: duplicate
Status: newclosed

Yep. Duplicate of #25528

Note: See TracTickets for help on using tickets.