Opened 12 months ago

Closed 6 months ago

#30910 closed defect (fixed)

Warning when pushing to tor.git: "disabling bitmap writing, as some objects are not being packed."

Reported by: nickm Owned by: tor-gitadm
Priority: Medium Milestone:
Component: Internal Services/Service - git Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi! I see this message when I push to tor.git.

remote: error: The last gc run reported the following. Please correct the root cause
remote: and remove gc.log.
remote: Automatic cleanup will not be performed until the file is removed.
remote: 
remote: warning: disabling bitmap writing, as some objects are not being packed
remote: 

Child Tickets

Change History (6)

comment:1 Changed 11 months ago by irl

Resolution: fixed
Status: newclosed

reopen if it needs more, but that should do it

comment:2 Changed 10 months ago by dgoulet

Resolution: fixed
Status: closedreopened

comment:3 Changed 10 months ago by emmapeel

I also it again in several branches of the translation git, as already stated at #28456

comment:4 Changed 8 months ago by arma

Is fixing this something that can be automated? Or if not, automatically detecting that it's happened to any of the git repos so somebody can go poke them?

comment:5 Changed 7 months ago by irl

It is not clear to me what the "root cause" is.

comment:6 Changed 6 months ago by irl

Resolution: fixed
Status: reopenedclosed

Ok, trying out a reduced expiry time for pruning to see if that helps.

Note: See TracTickets for help on using tickets.