Opened 4 weeks ago

Closed 3 weeks ago

#30919 closed defect (fixed)

Performance graphs are missing data from Torperf instances

Reported by: karsten Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Statistics Version:
Severity: Normal Keywords:
Cc: metrics-team, mikeperry Actual Points:
Parent ID: Points:
Reviewer: irl Sponsor:

Description

Yesterday we noticed that the performance graphs do not contain any data from Torperf instances anymore.

Here's why: when we excluded v3 onion measurements we accidentally required Torperf results to contain the ENDPOINTREMOTE key-value pair, but that was added by OnionPerf and not included by Torperf. The fix is trivial in that we simply need to check that column for NULL.

I'll post a patch shortly. Given that the fix is really trivial and we want to look at the data this week, I'm merging and deploying without waiting for a review. I'll put this ticket into needs_review anyway, just in case I screw up now, so that we can fix that later.

Child Tickets

Change History (3)

comment:1 Changed 4 weeks ago by karsten

Status: newneeds_review

Here's the patch. It's deployed, but it'll take 24 hours to become effective (because we're a few minutes too late for the current update run). If the graphs look better tomorrow and the patch makes sense, too, we can close this ticket.

comment:2 Changed 3 weeks ago by irl

Status: needs_reviewmerge_ready

I see what happened there, oops.

LGTM.

comment:3 Changed 3 weeks ago by karsten

Resolution: fixed
Status: merge_readyclosed

Thanks for checking! It's already merged and deployed, so I'm closing the ticket now.

Note: See TracTickets for help on using tickets.