Opened 12 months ago

Closed 3 months ago

#30954 closed enhancement (duplicate)

Address torrc option is ignored if set second time for the IPv6 address

Reported by: s7r Owned by: neel
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: ipv6
Cc: neel Actual Points:
Parent ID: #33233 Points:
Reviewer: Sponsor:

Description

Currently if we specify Address 2 times in the same torrc, once for IPv4 address and once for IPv6 address, it will just ignore the second entry as like it would be for the same IP family:

[warn] Option 'Address' used more than once; all but the last value will be ignored.

This behavior is perfect for cases where operators specify more addresses from the same family (like IPv4 for example) in the same torrc. I am marking this Low priority because it's here only to remind us about it when IPv6 autodetection will be implemented.

I know currently does not do IPv6 address detection so I am guessing this is why it currently does not care to learn about an IPv6 address from Address torrc setting, and only from ORPort to build just descriptors and be optimistic about getting the ReachableIPv6 flag, but when this changes it should be possible to specify Address 2 times in torrc, once for IPv4 and once for IPv6, the same as for OutboundBindAddress | OutboundBindAddressOR | OutboundBindAddressExit.

Child Tickets

Change History (11)

comment:1 Changed 12 months ago by teor

Milestone: Tor: unspecified
Parent ID: #24403
Type: defectenhancement
Version: Tor: 0.4.1.2-alphaTor: unspecified

Address behaves as documented in the man page, so this is a feature request.

comment:2 Changed 5 months ago by neel

Cc: neel added
Owner: set to neel
Status: newassigned

comment:3 Changed 5 months ago by teor

Parent ID: #24403#5940

Needed for #5940

comment:4 Changed 3 months ago by neel

Cc: neel removed
Owner: neel deleted

comment:5 Changed 3 months ago by neel

Status: assignednew

comment:6 Changed 3 months ago by neel

Owner: set to neel
Status: newassigned

comment:7 Changed 3 months ago by neel

Owner: neel deleted

comment:8 Changed 3 months ago by neel

Status: assignednew

comment:9 Changed 3 months ago by neel

Cc: neel added
Owner: set to neel
Status: newassigned

comment:10 Changed 3 months ago by teor

Hi neel, this ticket is part of ticket #33049 for the Sponsor 55 "Improve Tor Relay IPv6 Support" project.

We won't be able to make much progress here until we finish ticket #33048 "Relay IPv6 ORPort Reachability Self-Checks".

comment:11 Changed 3 months ago by teor

Parent ID: #5940#33233
Resolution: duplicate
Status: assignedclosed

Hmm actually this ticket is a duplicate of ticket #33233 "Make the Address torrc Option Support IPv6 Literals".

Note: See TracTickets for help on using tickets.