Opened 5 months ago

Closed 5 months ago

#30988 closed defect (worksforme)

No sound

Reported by: arkadiy Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: audio sound
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The browser is silent. I tried watching a video through a service below and no audio can be heard.

http://axqzx4s6s54s32yentfqojs3x5i7faxza6xo3ehd4bzzsg2ii4fv2iid.onion/

8.5.3 (based on Mozilla Firefox 60.7.0esr) (64-bit)

Child Tickets

Change History (3)

comment:1 Changed 5 months ago by gk

Status: newneeds_information

What operating system are you on? Does a vanilla Firefox ESR 60 work for you on such a system (bundles can be found at: https://www.mozilla.org/en-US/firefox/organizations/all/

Version 0, edited 5 months ago by gk (next)

comment:2 Changed 5 months ago by arkadiy

I'm using Debian buster/sid. There is sound coming out of vanilla Firefox ESR 60.7.2

comment:3 in reply to:  2 Changed 5 months ago by gk

Resolution: worksforme
Status: needs_informationclosed

Replying to arkadiy:

I'm using Debian buster/sid. There is sound coming out of vanilla Firefox ESR 60.7.2

Did you test one of the bundles I linked to above or the Firefox that comes with Debian? The reason why I am asking is they are compiled differently. The Debian one is enabling ALSA but that is not recommended as this option is deprecated. PulseAudio is the new requirement: https://bugzilla.mozilla.org/show_bug.cgi?id=1247056. So, I think the problem is that you don't have PulseAudio properly running on your system. Once you fix that you should get back the audio in Tor Browser. Please reopen the bug if I am wrong.

Note: See TracTickets for help on using tickets.