Opened 7 weeks ago

Closed 5 weeks ago

#31112 closed defect (fixed)

remove specified target_hopnum from relay-side machines

Reported by: pulls Owned by:
Priority: Medium Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version: Tor: 0.4.1.3-alpha
Severity: Normal Keywords: wtf-pad
Cc: asn, mikeperry, gaba Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For circuit padding machines, the target_hopnumfield in struct circpad_machine_spec_tis only for origin-side machines. Currently, the relay side of the two onion-related machines set the field. This should be safe to remove. PR here: https://github.com/torproject/tor/pull/1170.

Child Tickets

Change History (7)

comment:1 Changed 7 weeks ago by teor

Status: newneeds_review

comment:2 Changed 6 weeks ago by asn

Status: needs_reviewmerge_ready

LGTM!

comment:3 Changed 5 weeks ago by nickm

Milestone: Tor: 0.4.1.x-final

comment:4 Changed 5 weeks ago by nickm

Hi! My open question here is how tested this is, whether it presents any stability risk, and whether it should go into 0.4.1.x.

comment:5 Changed 5 weeks ago by asn

Hello. This is tested by running the usual padanalyzer script and making sure that the machines pad effectively. I don't think it presents any stability risk (which can also be verified with code reading) but since this is not a bugfix I think we can put it into master.

You can find it along with #31098 and a changes file in https://github.com/torproject/tor/pull/1185 .

Last edited 5 weeks ago by asn (previous) (diff)

comment:6 Changed 5 weeks ago by asn

Keywords: wtf-pad added
Milestone: Tor: 0.4.1.x-finalTor: 0.4.2.x-final

comment:7 Changed 5 weeks ago by nickm

Resolution: fixed
Status: merge_readyclosed

Thanks for the explanation! Merged to master; not backporting.

Note: See TracTickets for help on using tickets.