Opened 4 months ago

Closed 2 months ago

Last modified 6 weeks ago

#31136 closed defect (duplicate)

tor_bug_occurred_() channel_tls_handle_cell: This line should not have been reached.

Reported by: fingau Owned by:
Priority: Medium Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version: Tor: 0.3.5.8
Severity: Normal Keywords: tor-relay, tor-channel, 042-should
Cc: Actual Points:
Parent ID: #31107 Points:
Reviewer: Sponsor:

Description

OS:
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

Relay fingerprint:
C8F402FDF89E5B51D862AD68D8C17DFA5A371BA0

The log:
Jul 10 16:15:55.000 [notice] Heartbeat: Tor's uptime is 6:00 hours, with 5886 circuits open. I've sent 86.93 GB and received 86.12 GB.
Jul 10 16:15:55.000 [notice] Circuit handshake stats since last time: 9041/9041 TAP, 174017/174017 NTor.
Jul 10 16:15:55.000 [notice] Since startup we initiated 0 and received 122 v1 connections; initiated 0 and received 434 v2 connections; initiated 0 and received 784 v3 connections; initiated 2816 and received 9410 v4 connections; initiated 5175 and received 8815 v5 connections.
Jul 10 16:15:55.000 [notice] DoS mitigation since startup: 0 circuits killed with too many cells. 0 circuits rejected, 0 marked addresses. 0 connections closed. 6 single hop clients refused.
Jul 10 21:12:34.000 [warn] tor_bug_occurred_(): Bug: ../src/core/or/channeltls.c:1111: channel_tls_handle_cell: This line should not have been reached. (Future instances of this warning will be silenced.) (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: Line unexpectedly reached at channel_tls_handle_cell at ../src/core/or/channeltls.c:1111. Stack trace: (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(log_backtrace_impl+0x45) [0x55d26b5fd995] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(tor_bug_occurred_+0xc0) [0x55d26b5f9040] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(channel_tls_handle_cell+0x3da) [0x55d26b4855da] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(+0x9c20c) [0x55d26b4a920c] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(connection_handle_read+0x9bd) [0x55d26b472f7d] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(+0x6bdae) [0x55d26b478dae] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/lib/x86_64-linux-gnu/libevent-2.1.so.6(+0x1e8f8) [0x7f887bf338f8] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/lib/x86_64-linux-gnu/libevent-2.1.so.6(event_base_loop+0x53f) [0x7f887bf3433f] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(do_main_loop+0xb9) [0x55d26b47a1c9] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(tor_run_main+0x128d) [0x55d26b46803d] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(tor_main+0x3a) [0x55d26b4650fa] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(main+0x19) [0x55d26b464c89] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /lib/x86_64-linux-gnu/libc.so.6(libc_start_main+0xe7) [0x7f887a65cb97] (on Tor 0.3.5.8 )
Jul 10 21:12:34.000 [warn] Bug: /usr/bin/tor(_start+0x2a) [0x55d26b464cda] (on Tor 0.3.5.8 )
Jul 10 22:15:55.000 [notice] Heartbeat: Tor's uptime is 12:00 hours, with 6319 circuits open. I've sent 220.48 GB and received 218.85 GB.
Jul 10 22:15:55.000 [notice] Circuit handshake stats since last time: 10090/10090 TAP, 208653/208653 NTor.
Jul 10 22:15:55.000 [notice] Since startup we initiated 0 and received 326 v1 connections; initiated 0 and received 1088 v2 connections; initiated 0 and received 1909 v3 connections; initiated 5587 and received 24432 v4 connections; initiated 8005 and received 17206 v5 connections.
Jul 10 22:15:55.000 [notice] DoS mitigation since startup: 0 circuits killed with too many cells. 0 circuits rejected, 0 marked addresses. 0 connections closed. 10 single hop clients refused.

Child Tickets

Change History (6)

comment:1 Changed 4 months ago by nickm

Keywords: 041-backport 040-backport 035-backport added
Milestone: Tor: 0.4.2.x-final

comment:2 Changed 4 months ago by nickm

See also #31221, a possible duplicate.

comment:3 Changed 2 months ago by nickm

Keywords: security crash added

See also #31107 and #31221

comment:4 Changed 2 months ago by nickm

Keywords: 042-should added

comment:5 Changed 2 months ago by nickm

Keywords: security crash removed
Resolution: duplicate
Status: newclosed

Closing as duplicate of #31107.

comment:6 Changed 6 weeks ago by teor

Keywords: 041-backport 040-backport 035-backport removed
Note: See TracTickets for help on using tickets.