Opened 4 months ago

Closed 4 months ago

#31152 closed defect (worksforme)

Disqus broken again

Reported by: mwolfe Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Back in 2018, when Tor upgraded from 7 to 8, the Disqus comment management system stopped working with Tor. I could log in, but the log-in tab could not communicate with the comment tab, so the comment tab did not know I was logged in.

After some time, I enabled all 3rd party cookies, and was able to comment again.

My version of Tor for Mac had been upgraded many times, and stopped connecting due to some cruft it had picked up, so I installed the alpha version. I could connect easily, but I could no longer comment. I changed to allow all cookies, but the log-in tab still could not communicate with the comment tab.

I tried telling Noscript to enable everything on the tab, but no luck.

I switched off Private Mode, but no luck.

I tried to go back to the non-alpha version and downloaded a new copy to the Applications folder, but it could not connect. So I downloaded the non-alpha version to a private folder, and it can connect easily but cannot comment on Disqus.

Again, the log-in tab cannot communicate with the comment tab. When I click log-in a second or third time, I never see the log-in tab (since it knows I'm logged in) so it returns me to the comment tab, where I still cannot comment.

I went to Library and deleted everything that said it was from Tor, but still cannot comment.

Now I cannot comment on Disqus (used by many websites, such as Arcamax and Comics Kingdom). And none of the things that got Disqus working in 2018 work now.

Child Tickets

Change History (8)

comment:1 Changed 4 months ago by cypherpunks

How to test properly:

  1. Delete everything.
  2. Make a new installation of Tor Browser Alpha.
  3. Test.

If it doesn't work, enable 3rd-party cookies, restart, test.
If it doesn't work, disable NoScript, restart, test.
If it doesn't work, remove NoScript, restart, test.
If it doesn't work, report here.

comment:2 Changed 4 months ago by mwolfe

I just checked on my PC, and I can comment on Disqus. So the problem is only on my Mac (2010 Macbook Pro, OS X 11.6).

Item 1 is 'Delete everything' but I can tell Tor stores things in lots of places, and I have no idea where to find everything. List please.

I'll try deleting the version I've got and re-installing the latest versions 8 and 9 and see if any of them allow comments in Disqus in OSX 11.6.

comment:3 in reply to:  1 Changed 4 months ago by mwolfe

Replying to cypherpunks:

How to test properly:

  1. Delete everything.
  2. Make a new installation of Tor Browser Alpha.
  3. Test.

If it doesn't work, enable 3rd-party cookies, restart, test.
If it doesn't work, disable NoScript, restart, test.
If it doesn't work, remove NoScript, restart, test.
If it doesn't work, report here.

I just checked on my PC, and I can comment on Disqus. So the problem is only on my Mac (2010 Macbook Pro, OS X 11.6).

Item 1 is 'Delete everything' but I can tell Tor stores things in lots of places, and I have no idea where to find everything. List please.

I'll try deleting the version I've got and re-installing the latest versions 8 and 9 and see if any of them allow comments in Disqus in OSX 11.6.

comment:4 Changed 4 months ago by cypherpunks

If you see leftovers after doing https://support.torproject.org/tbb/tbb-28/ on Mac, please file a new ticket.

comment:5 Changed 4 months ago by nickm

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:6 in reply to:  1 Changed 4 months ago by mwolfe

Replying to cypherpunks:

How to test properly:

  1. Delete everything.
  2. Make a new installation of Tor Browser Alpha.
  3. Test.

If it doesn't work, enable 3rd-party cookies, restart, test.
If it doesn't work, disable NoScript, restart, test.
If it doesn't work, remove NoScript, restart, test.
If it doesn't work, report here.

TorBrowser-9.0a works fine on Windows, but on OSX 10.11.6, with TorBrowser-8.5.4-osx64 I have deleted everything, removed NoScript, set enable all cookies, turned Private Mode off, and when I click Login Disqus, after many, many Captchas I get logged in on the login tab and returned to the comment tab, where I am not logged in. If I click Login Disqus again, I do not see the login tab, it goes there, sees I'm logged in on the login tab, and returns me to the comment tab (none of which shows on the screen, I just see the comment tab) where I am not logged in.

I still have a copy of TorBrowser 7.5.6, where I can comment on Disqus. I think I could comment on TorBrowser 8.4 (but TorBrowser 8.4 knows not to let me install it, since a newer version is available). But on TorBrowser 8.5.4, no matter what I do, the Disqus login tab cannot communicate with the Disqus comment tab, and likewise TorBrowser-9.0a on OSX 10.11.6

comment:7 in reply to:  1 Changed 4 months ago by mwolfe

Replying to cypherpunks:

How to test properly:

  1. Delete everything.
  2. Make a new installation of Tor Browser Alpha.
  3. Test.

If it doesn't work, enable 3rd-party cookies, restart, test.
If it doesn't work, disable NoScript, restart, test.
If it doesn't work, remove NoScript, restart, test.
If it doesn't work, report here.

The problem was that my copy of OSX 10.11.6 somehow got corrupted, and the way it was corrupted prevented tabs from communicating in TorBrowser 8.0 and above, even with all cookies accepted. I could still comment in TorBrowser 7.5, because tabs communicate in a different way.

After deleting TorBrower from Applications and reinstalling several times, I still could not comment.

So I tried re-installing OSX, and now the tabs can communicate and I can comment in Disqus.

I have no idea what actually got corrupted, the only solution was to re-install OSX.

comment:8 Changed 4 months ago by gk

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.