Opened 3 months ago

Last modified 2 months ago

#31155 needs_information defect

Privacy with TOR

Reported by: Webster Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using the latest version of TOR to log on to my Wordpress blog.
However, Wordpress recently recognizes my PC, rendering TOR completely transparent.
Previously, when I visited the blog without logging on, it was counted as a unique visit each time.
But that is no longer the case.
How do I hide my ID from Wordpress again?

Child Tickets

Change History (6)

comment:1 Changed 3 months ago by nickm

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 3 months ago by gk

Resolution: not a bug
Status: newclosed

Sounds like WordPress changed something on their end? Maybe they count Tor users not as unique users anymore? Hard to say. AS it stands I don't see this being a Tor Browser bug. If you disagree, please provide more information so we can investigate. Like, what makes you believe this is a Tor Browser issue? On which operating system does that happen? (and anything else that could help us here investigating)

comment:3 Changed 3 months ago by Webster

Resolution: not a bug
Status: closedreopened

I used a different PC configured with Firefox/TOR to view my Wordpress blog and establish whether they count TOR users not as unique users anymore.
I then logged on to the blog using my own PC to monitor the internal hit counter and noticed that it had counted each and every hit made by the second PC.
Clearly, TOR offers zero anonymity when I use my own PC because Wordpress recognizes the dvice.

comment:4 Changed 3 months ago by gk

Resolution: not a bug
Status: reopenedclosed

I still don't see this as a Tor Browser bug given your latest comment. It seems you are not even using Tor Browser but some Firefox/Tor combination? Please answer the other questions in comment:2 as well before reopening this bug.

comment:5 Changed 2 months ago by Webster

Resolution: not a bug
Status: closedreopened

Four of my colleagues, who operate affiliated blogs with a progressive/political slant, also have identical problems hiding their identity from WordPress when using Tor.
Our PCs run Windows 10. We use Tor Browser to browse and log on to WordPress.
TOR Browser is no longer offering anonymity when we browse WordPress using our original PCs.

If the problem isn't rectified by August 12, we'd publicize the issue and inform other Tor users worldwide.

Last edited 2 months ago by Webster (previous) (diff)

comment:6 in reply to:  5 Changed 2 months ago by gk

Status: reopenedneeds_information

Replying to Webster:

Four of my colleagues, who operate affiliated blogs with a progressive/political slant, also have identical problems hiding their identity from WordPress when using Tor.
Our PCs run Windows 10. We use Tor Browser to browse and log on to WordPress.
TOR Browser is no longer offering anonymity when we browse WordPress using our original PCs.

Alright, so this problem happens with recent Tor Browser versions but did not show up earlier? If so, which is the first Tor Browser version that shows the problem? (older versions can be found at: https://archive.torproject.org/tor-package-archive/torbrowser/)

Note: See TracTickets for help on using tickets.