Opened 9 years ago

Closed 9 years ago

#3117 closed defect (duplicate)

"Find Bridges Now" functionality not working

Reported by: dererk Owned by: chiiph
Priority: High Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Quoting from bugs.debian.org/625799:
"when I try to retrieve new bridges configuration using the dedicated
button "Find bridges now" in the Network panel of the Settings window, I
got the following messages in the dialog box:

  • Connecting to bridges.torproject.org:443...
  • Sending an HTTPS request for bridges...
  • Unable to download bridges: HTTP request failed

If I try to access the webpage https://bridges.torproject.org using my
web browser, "it works".

I can't find more information in the log or the console output of
Vidalia."

I was able to reproduce it and confirm its indeed asking for "bridges.torproject.org" DNS record. Moreover, it correctly performs a secure handshake up to the very instant the "HTTP Request failed" message appears, which leads me to think a change in the URL or something in that part is making this to fail.

Please let me know if I can be any more help to you.

Child Tickets

Change History (1)

comment:1 Changed 9 years ago by chiiph

Resolution: duplicate
Status: newclosed

This is a duplicate of #2835. The problem has been solved, the fix will be available first on 0.3.0-alpha and later on 0.2.13.

Thanks for reporting it though :)

Note: See TracTickets for help on using tickets.