#31171 closed defect (duplicate)

GTK user settings overwritten by TOR-browser's File-Chooser Dialog

Reported by: schappi Owned by:
Priority: Medium Milestone:
Component: Applications Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I got the issue that whenever I saved a file from the TOR browser, my gtk-setting to sort folders before files got changed by the file-chooser dialog. This globally affects apps like nautilus as well.

Actually, the file-chooser seems to ignore the current settings in "org/gtk/settings/file-chooser/sort-directories-first" and uses some defaults. However, the settings are written-back to the global config, thus probably causing the issue.

Would be good to load settings in the file-chooser dialog in advance or discard writing later.

Child Tickets

Change History (1)

comment:1 Changed 13 months ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #27903.

Note: See TracTickets for help on using tickets.