Opened 13 months ago

Closed 6 months ago

#31179 closed task (duplicate)

Eliminate non tor_queue.h linked lists.

Reported by: nickm Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: teor, catalyst Actual Points:
Parent ID: Points: 8
Reviewer: Sponsor:

Description

We should use tor_queue.h in place of anywhere that we currently manually manage a next and prev. (This may be a duplicate.)

We are planning to only do a couple of these for S31, though we might do more, time permitting.

Child Tickets

Change History (6)

comment:1 Changed 13 months ago by gaba

Keywords: network-team-roadmap-november added
Points: 8

comment:2 Changed 13 months ago by gaba

Keywords: network-team-roadmap-october added; network-team-roadmap-november removed

comment:3 Changed 12 months ago by arma

Cc: catalyst added; taylor removed

comment:4 Changed 7 months ago by gaba

Sponsor: Sponsor31-can

Sponsor closed. Remove from roadmap.

comment:5 Changed 7 months ago by gaba

Keywords: network-team-roadmap-october removed

comment:6 Changed 6 months ago by catalyst

Resolution: duplicate
Status: newclosed

duplicate of #7479

Note: See TracTickets for help on using tickets.