Opened 7 months ago

Closed 7 months ago

Last modified 2 months ago

#31222 closed defect (fixed)

Remove/or Improve Tor Browser detection in snowflake.js

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Circumvention/Snowflake Version:
Severity: Normal Keywords: snowflake-webextension
Cc: arlolra, cohosh, phw, dcf Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Right now the code seems to be outdated,

Util.TBB_UAS = [
  'Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0',
  'Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0',
  'Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0',
  'Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0'
];

Nowadays people enabling RFP in Firefox will get the same UA as TB, so using the UA alone is not sufficient. I suggest either removing this (snowflake won't work either way, it's better to just say that WebRTC is disabled) or improving it with some other heuristic for detecting TB.

Child Tickets

Change History (6)

comment:1 Changed 7 months ago by cohosh

We had a discussion about this at the meeting last week. I think the decision was to remove this code since it doesn't work as intended anyway.

There was also a discussion just now in #tor about this that brought up several points:

  • People seem to be concerned about the safety issues with running WebRTC in Tor Browser. Do we have a good understanding of this?
  • [Adding question from IRC] Actually how would this even work? Would the proxied traffic go through Tor as well? Is this desirable?

I suggest removing the code since it doesn't work, and letting the lack of WebRTC support take care of the rest.

Last edited 7 months ago by cohosh (previous) (diff)

comment:2 Changed 7 months ago by cohosh

Keywords: snowflake-webextension added

comment:3 in reply to:  1 Changed 7 months ago by arma

Replying to cohosh:

  • People seem to be concerned about the safety issues with running WebRTC in Tor Browser. Do we have a good understanding of this?

Yes: the Firefox webrtc code is full of proxy bypass bugs. That is, the webrtc code will make network connections that bypass your proxy settings. That's why Tor Browser compiles it out: #8178.

I talked to tjr about the issue at one of the Moz All Handses, and he seemed to think it would be a lot of work on the Firefox side to fix.

comment:4 in reply to:  1 Changed 7 months ago by dcf

Replying to cohosh:

I suggest removing the code since it doesn't work, and letting the lack of WebRTC support take care of the rest.

Yes, I think that is a good call.

comment:5 Changed 7 months ago by cohosh

Resolution: fixed
Status: newclosed

arlolra fixed this in https://github.com/keroserene/snowflake/commit/8385e7c2dab3e587ce63cc522d3a667b02c949b8

It's been merged with that branch from #27385

comment:6 Changed 2 months ago by Tolyatex

...

Note: See TracTickets for help on using tickets.