Opened 7 months ago

Closed 7 months ago

#31259 closed defect (not a bug)

Snowflake Broker Returns 504 Error When Using Go Proxy Server

Reported by: cypherpunks Owned by:
Priority: High Milestone:
Component: Circumvention Version: Tor: unspecified
Severity: Critical Keywords: snowflake-server golang proxy-go
Cc: cohosh, phw Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Title. Here's the output log:

2019/07/29 01:42:33 starting
INFO: configuration.go:174: Created Configuration at &{[{[stun:stun.l.google.com:19302] }] All Balanced }
2019/07/29 01:42:44 broker returns: 504
2019/07/29 01:42:54 broker returns: 504
2019/07/29 01:43:05 broker returns: 504

This continues and the server does not run.

Child Tickets

Change History (2)

comment:1 Changed 7 months ago by cohosh

That's normal, a return of 504 means that there were no clients that needed to use the server during that poll period. See https://github.com/ahf/snowflake-notes/blob/master/Broker.markdown#the-proxy-handler

What do you mean by "the server does not run"?

We could make a note to improve the log output to not cause operators to worry in #30830.

comment:2 Changed 7 months ago by cohosh

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.