Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#31307 closed defect (fixed)

Gettor doesn't seem to be responding to email requests

Reported by: pili Owned by:
Priority: Very High Milestone:
Component: Applications/GetTor Version:
Severity: Normal Keywords:
Cc: traumschule, hiro, gaba Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I just emailed gettor@… with subject: windows and I have not received any email back from it.

Can someone check whether everything is up and running?

Child Tickets

Change History (3)

comment:1 Changed 3 months ago by phw

I also didn't get a response over email.

GetTor needs a "survival guide" that allows people other than the maintainer to resurrect the service. Here are the anti-censorship team's survival guides: https://trac.torproject.org/projects/tor/wiki/org/teams/AntiCensorshipTeam#Servicesurvivalguides

I also filed #31312 to get access to GetTor's machine. I may be able to restart GetTor.

comment:2 Changed 3 months ago by phw

Resolution: fixed
Status: newclosed

I believe that the problem is now fixed. It looks like the script ~/gettor/scripts/add_lins_to_db was the culprit. In particular lines 56-58. The script assumes a list of length 12 but the page over at https://www.torproject.org/projects/torbrowser/RecommendedTBBVersions/ currently returns [ "8.5.4", "8.5.4-MacOS", "8.5.4-Linux", "8.5.4-Windows", "9.0a4", "9.0a4-MacOS", "9.0a4-Linux", "9.0a4-Windows" ], a list that counts only 8 elements. I added an emergency fix that changes

version = versions.split(",")[-12]

to

version = versions.split(",")[0]

I was able to re-generate the database and restart GetTor.

Besides, boklm mentions on IRC that RecommendedTBBVersions is not a good way to learn about the current Tor Browser version:

 20:46  boklm│ RecommendedTBBVersions is not a good way to get the current Tor Browser version
 20:47  boklm│ https://aus1.torproject.org/torbrowser/update_3/release/downloads.json is better
 20:48  boklm│ for example with: wget -q -O - https://aus1.torproject.org/torbrowser/update_3/release/downloads.json | jq -r .version

I'll file a separate ticket to make GetTor more robust in this regard.

comment:3 in reply to:  2 Changed 3 months ago by boklm

Replying to phw:

Besides, boklm mentions on IRC that RecommendedTBBVersions is not a good way to learn about the current Tor Browser version:

The reason that RecommendedTBBVersions is not a good way for that is that it contains both alpha and stable versions, and sometimes both the current and previous versions, so it makes it not easy to find which one in the list is the current stable version.

Note: See TracTickets for help on using tickets.