Opened 8 years ago

Closed 8 years ago

#3133 closed defect (duplicate)

Firefox in Linux experimental TBB loads system plugins

Reported by: P4C0 Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After calling ./start-tor-browser --debug

Vidalia connects to tor network and fails to start firefox:

[notice] Tor status changed from 'Authenticating' to 'Authenticated'.
[debug] QtDebugMsg: torcontrol: Control Command: SETEVENTS BW NOTICE WARN ERR CIRC STREAM NEWDESC ADDRMAP STATUS_GENERAL STATUS_CLIENT STATUS_SERVER
[debug] QtDebugMsg: torcontrol: Control Reply: 250 OK
[debug] QtDebugMsg: torcontrol: Control Command: GETINFO status/circuit-established
[debug] QtDebugMsg: torcontrol: Control Reply: 250 status/circuit-established=1 250 OK
[notice] Tor status changed from 'Authenticated' to 'Circuit Established'.
[notice] Launching helper process './App/Firefox/firefox' with arguments '-profile ./Data/profile'
[debug] QtDebugMsg: torcontrol: Control Command: GETINFO status/version/current
[debug] QtDebugMsg: torcontrol: Control Reply: 250 status/version/current=recommended 250 OK
[debug] QtDebugMsg: torcontrol: Control Command: GETINFO status/bootstrap-phase
[debug] QtDebugMsg: torcontrol: Control Reply: 250 status/bootstrap-phase=NOTICE BOOTSTRAP PROGRESS=100 TAG=done SUMMARY="Done" 250 OK
[debug] QtDebugMsg: torcontrol: Control Event: 650 CIRC 10 EXTENDED $69C4BAE523AF3B203653A14E9EE6F67F6C611790=archivetpo,$9978A3E7F29B6B846EE730B1BE6E5E7E46BF8A50=Pandora22 PURPOSE=GENERAL
[debug] QtDebugMsg: torcontrol: Control Event: 650 CIRC 12 EXTENDED $1FE3D5979AC24A431C957463FE0ED42C295135BB=BarkerJrPhoenix,$7719A451319DFF7F965701B49C29C74B4BF217C0~PPrivCom012 PURPOSE=GENERAL
[info] (firefox:stderr): Error in XML file: [xpconnect wrapped nsIFile]
[info] (firefox:stderr): SyntaxError: unexpected end of XML entity
[info] (firefox:stderr): 
[info] (firefox:stderr): Error in XML file: [xpconnect wrapped nsIFile]
[info] (firefox:stderr): SyntaxError: invalid XML tag syntax
[info] (firefox:stderr): 
[debug] QtDebugMsg: torcontrol: Control Event: 650 BW 1758 2344
[info] (firefox:stderr): ./App/Firefox/firefox-bin: symbol lookup error: /usr/lib/mozilla/plugins/skypebuttons.so: undefined symbol: _ZN9QListData11detach_growEPii
[info] (firefox:stderr): 
[notice] Cleaning up before exiting.
[debug] QtDebugMsg: torcontrol: Control Command: SIGNAL HALT
[debug] QtDebugMsg: torcontrol: Control Reply: 250 OK
[notice] Vidalia is exiting cleanly (return code 0).
[notice] QtWarningMsg: torcontrol: Tor closed the control connection.
[debug] QtDebugMsg: torcontrol: Control connection status changed from 'Connected' to 'Disconnected'
[debug] QtDebugMsg: torcontrol: Exited control connection event loop.
[debug] QtDebugMsg: torcontrol: Stopping the Tor process.

Happens with:
tor-browser-gnu-linux-x86_64-2.2.25-1-alpha-en-US.tar.gz
tor-browser-gnu-linux-x86_64-1.1.8-dev-en-US.tar.gz
tor-browser-gnu-linux-i686-1.1.8-dev-en-US.tar.gz

Linux distribution: Arch Linux

Child Tickets

Change History (7)

comment:1 Changed 8 years ago by arma

[info] (firefox:stderr): ./App/Firefox/firefox-bin: symbol lookup error: /usr/lib/mozilla/plugins/skypebuttons.so: undefined symbol: _ZN9QListData11detach_growEPii

Yuck. It looks like TBB's Firefox is looking through your filesystem to find plugins to load.

comment:2 Changed 8 years ago by arma

(The user confirms on irc that he does in fact have a /usr/lib/mozilla/plugins/skypebuttons.so file)

comment:4 Changed 8 years ago by dspeed

Confirmed that the bug is still present in the alpha above.

I also have definitely got the skypebuttons.so and am running latest Kubuntu 11.04

comment:5 Changed 8 years ago by dspeed

There's a workaround for this by removing the skypebuttons.so from /usr/lib/mozilla/plugins, obviously

comment:6 Changed 8 years ago by rransom

Owner: changed from erinn to mikeperry
Status: needs_informationassigned
Summary: Linux: Firefox doesn't start, Vidalia exitsFirefox in Linux experimental TBB loads system plugins

comment:7 Changed 8 years ago by mikeperry

Resolution: duplicate
Status: assignedclosed

I'm going to dup this to #3547. That is the ticket to directly hack the Firefox source to prevent all plugins except flash from even being loaded into the TorBrowser process space. #3547 will be fixed before we call TBB 2.2.x "stable".

Note: See TracTickets for help on using tickets.