Opened 3 months ago

Closed 3 months ago

#31346 closed task (duplicate)

Tor Browser 8.5.4 gvfs-metadata recently-used.xbel

Reported by: randosando Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When you save a file using the Tor Browser, a folder is created;

"tor-browser_en-US/Browser/.local/share"

This folder does not exist when first extracting the folder.

In this folder is the file;

recently-used.xbel

and the folder; gvfs-metadata

The recently-used.xbel file has a list of all the files you downloaded. Clearing your downloads in the browser does not clear this file, nor does it clear when you close the tor browser.

The gvfs-metadata folder has two files, a binary and a log file;
home
home-abc12345.log

When deleting the tor browser folder, you will be unable to remove the folder because the two files within the gvfs-metadata folder are kept open by the gvfs-metadata process. The gvfs-metadata process needs to be killed before the gvfs-metadata folder and its contents can be removed.

Child Tickets

Change History (2)

comment:1 Changed 3 months ago by arma

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team
Priority: HighMedium
Version: Tor: unspecified

Looks like #8706?

comment:2 Changed 3 months ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #8706.

Note: See TracTickets for help on using tickets.