Opened 4 months ago

Closed 3 months ago

Last modified 2 months ago

#31380 closed defect (fixed)

/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by ./TorBrowser/Tor/PluggableTransports/snowflake-client)

Reported by: xhdix Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: snowflake, tbb-rbm
Cc: dcf, boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Similar to the Ticket #25485 but in the new alpha version when using the snowflake bridge.

8/8/19, 18:31:25.542 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/8/19, 18:31:31.914 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/8/19, 18:31:31.914 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/8/19, 18:31:31.914 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections. 
8/8/19, 18:31:31.914 [NOTICE] Opening Socks listener on 127.0.0.1:9150 
8/8/19, 18:31:31.914 [NOTICE] Opened Socks listener on 127.0.0.1:9150 
8/8/19, 18:31:32.212 [WARN] Managed proxy at './TorBrowser/Tor/PluggableTransports/snowflake-client' reported: ./TorBrowser/Tor/PluggableTransports/snowflake-client: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by ./TorBrowser/Tor/PluggableTransports/snowflake-client) 
8/8/19, 18:31:32.216 [WARN] Pluggable Transport process terminated with status code 256 

Child Tickets

Change History (16)

comment:1 Changed 4 months ago by xhdix

Debug mode:

 ./start-tor-browser --debug
Aug 08 19:16:01.985 [notice] Tor 0.4.1.3-alpha (git-d2c360c5336b43ba) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.1.1c, Zlib 1.2.8, Liblzma N/A, and Libzstd N/A.
Aug 08 19:16:01.985 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Aug 08 19:16:01.985 [notice] This version is not a stable Tor release. Expect more bugs than usual.
Aug 08 19:16:01.985 [notice] Read configuration file "/home/mk/Desktop/Browser/TorBrowser/Data/Tor/torrc-defaults".
Aug 08 19:16:01.986 [notice] Read configuration file "/home/mk/Desktop/Browser/TorBrowser/Data/Tor/torrc".
Aug 08 19:16:01.996 [notice] Opening Control listener on 127.0.0.1:9151
Aug 08 19:16:02.000 [notice] Opened Control listener on 127.0.0.1:9151
Aug 08 19:16:02.000 [notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
Aug 08 19:16:02.000 [notice] Parsing GEOIP IPv4 file /home/mk/Desktop/Browser/TorBrowser/Data/Tor/geoip.
Aug 08 19:16:02.000 [notice] Parsing GEOIP IPv6 file /home/mk/Desktop/Browser/TorBrowser/Data/Tor/geoip6.
Aug 08 19:16:02.000 [notice] Bootstrapped 0% (starting): Starting
Aug 08 19:16:02.000 [notice] Starting with guard context "bridges"
Aug 08 19:16:02.000 [notice] Delaying directory fetches: DisableNetwork is set.
Aug 08 19:16:02.000 [notice] New control connection opened from 127.0.0.1.
Aug 08 19:16:02.000 [notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
Aug 08 19:16:02.000 [notice] New control connection opened from 127.0.0.1.
Aug 08 19:16:02.000 [notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
Aug 08 19:16:02.000 [notice] Opening Socks listener on 127.0.0.1:9150
Aug 08 19:16:02.000 [notice] Opened Socks listener on 127.0.0.1:9150
Aug 08 19:16:03.000 [warn] Managed proxy at './TorBrowser/Tor/PluggableTransports/snowflake-client' reported: ./TorBrowser/Tor/PluggableTransports/snowflake-client: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by ./TorBrowser/Tor/PluggableTransports/snowflake-client)
Aug 08 19:16:03.000 [warn] Pluggable Transport process terminated with status code 256

comment:2 Changed 4 months ago by dcf

Cc: dcf added

comment:3 Changed 4 months ago by gk

Keywords: tbb-rbm added
Status: newneeds_information

What Linux is that on? Is that a new thing or did you have the problem for a while now on your machine?

comment:4 Changed 4 months ago by xhdix

@gk Newly installed Debian!
I use this Linux to test programs. Simple and without any specific changes.
Need more information?

comment:5 Changed 3 months ago by dcf

I'm not able to reproduce this with a newly installed Debian 10.

I installed in a brand new VM using debian-10.0.0-amd64-netinst.iso. I downloaded tor-browser-linux64-9.0a4_en-US.tar.xz. It took a few tries to find a working proxy, but I was able to bootstrap using snowflake. I'm also able to run snowflake-client in the terminal.

$ cat /etc/debian_version
10.0
$ uname -a
Linux debian 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86_64 GNU/Linux
$ dpkg -s libstdc++6 | grep ^Version
Version: 8.3.0-6
$ Browser/TorBrowser/Tor/PluggableTransports/snowflake-client -h
Usage of ./Browser/TorBrowser/Tor/PluggableTransports/snowflake-client:
  -front string
        front domain
...

comment:6 Changed 3 months ago by xhdix

I installed it with debian-9.8.0-amd64-netinst.iso.

$ cat /etc/debian_version
9.9
$ uname -a
Linux oonimk 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u4 (2019-07-19) x86_64 GNU/Linux
$ dpkg -s libstdc++6 | grep ^Version
Version: 6.3.0-18+deb9u1
$ Desktop/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client -h
Desktop/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by Desktop/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client)

comment:7 in reply to:  6 ; Changed 3 months ago by gk

Replying to xhdix:

I installed it with debian-9.8.0-amd64-netinst.iso.

$ cat /etc/debian_version
9.9
$ uname -a
Linux oonimk 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u4 (2019-07-19) x86_64 GNU/Linux
$ dpkg -s libstdc++6 | grep ^Version
Version: 6.3.0-18+deb9u1
$ Desktop/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client -h
Desktop/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by Desktop/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client)

Can you check whether 9.0a1 is still working for you (and 9.0a2 the first version that breaks)? You find both at: https://archive.torproject.org/tor-package-archive/torbrowser/

comment:8 in reply to:  7 Changed 3 months ago by xhdix

Replying to gk:

Can you check whether 9.0a1 is still working for you (and 9.0a2 the first version that breaks)? You find both at: https://archive.torproject.org/tor-package-archive/torbrowser/

Yes, version 9.0a1 works for me.

$ ./tora1/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client -h
Usage of ./tora1/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client:
  -front string
    	front domain
  -ice string
    	comma-separated list of ICE servers
  -log string
    	name of log file
  -logToStateDir
    	resolve the log file relative to tor's pt state dir
  -max int
    	capacity for number of multiplexed WebRTC peers (default 1)
  -url string
    	URL of signaling broker

$ ./tora2/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client -h
./tora2/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by ./tora2/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client)

$ ./tora4/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client -h
./tora4/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by ./tora4/Browser/TorBrowser/Tor/PluggableTransports/snowflake-client)
Last edited 3 months ago by xhdix (previous) (diff)

comment:9 Changed 3 months ago by arma

gk, what is different with 9.02a vs 9.01a?

comment:10 in reply to:  9 Changed 3 months ago by gk

Cc: boklm added
Status: needs_informationnew

Replying to arma:

gk, what is different with 9.02a vs 9.01a?

We bumped the GCC version for Linux bundles to 8.3.0 (from 6.4.0). However, it is weird that this is affecting only snowflake. I'd suspect either the whole bundle would not work if Tor Browser gets started the recommended way or everything...

comment:11 Changed 3 months ago by boklm

I think this issue will by fixed by #31646.

comment:12 Changed 3 months ago by cypherpunks

However, it is weird that this is affecting only snowflake.

snowflake-client uses some new function that requires CXXABI_1.3.11, others don't.

comment:13 Changed 3 months ago by gk

Resolution: fixed
Status: newclosed

This should be fixed by #31646. However, I still don't really understand why Tor Browser started properly but snowflake barfed. Please reopen the ticket if the next alpha (9.0a7) is still broken for you.

comment:14 in reply to:  13 Changed 3 months ago by boklm

Replying to gk:

However, I still don't really understand why Tor Browser started properly but snowflake barfed.

I think that although we built it using gcc 8.3.0, by chance the browser did not use any of the functions added in the new libstdc++, so it was still compatible with the libstdc++ provided by Debian 9. However this changed with the switch to esr68 and this now prevents the browser from starting too (which should be fixed by #31646).

comment:15 in reply to:  13 Changed 3 months ago by xhdix

Replying to gk:

Please reopen the ticket if the next alpha (9.0a7) is still broken for you.

Thanks. When will the next alpha be released?

comment:16 Changed 2 months ago by xhdix

I tested version 9.0a7. No problem. Thanks

Note: See TracTickets for help on using tickets.