Opened 6 weeks ago

Closed 6 weeks ago

Last modified 5 weeks ago

#31393 closed defect (wontfix)

Stop declaring support for Padding=1 after 0.4.1-stable is released

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: wtf-pad, technical-debt
Cc: Actual Points:
Parent ID: #31356 Points: 0.2
Reviewer: Sponsor: Sponsor2

Description

Once 0.4.1-stable is released (and on deb.tpo as the stable version), there will be a lot of relays with Padding=2. So we can stop declaring support for Padding=1.

Child Tickets

Change History (2)

comment:1 Changed 6 weeks ago by teor

Resolution: wontfix
Status: newclosed

We don't need to preserve compatibility with alphas, so we can stop declaring Padding=1 immediately.

comment:2 Changed 5 weeks ago by teor

Keywords: merge-after-041-stable 040-backport 041-backport removed

No backports on wontfix tickets.

Note: See TracTickets for help on using tickets.