Opened 3 months ago

Last modified 3 months ago

#31432 needs_information defect

Tor Browser 8.5.4 will not start up

Reported by: phplearner Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Some days ago, my tor Browser updated automatically to 8.5.4 version from its previous version. after that tor browser does not starts. I tried many guides from the web, but no success.
I have had Tor Browser previous versions tar.xz file on my computer, I deleted 8.5.4 version folder and extracted previous version (5.5.2) and it worked properly.
But after automatic update, it did not started again. So I deleted "tor-browser_en-US" folder and extracted it again from tor-browser-linux64-5.5.2_en-US.tar.xz file. But it did not started!!
I have to use another previous version, i.e. 5.5.4, and after automatic update to 8.5.4 version it did not started again and I have to use another previous version, i.e. 6.0, so I disabled automatic update of tor to work around the problem. Who can find the reason of this problem and guide me to solve it?

Child Tickets

Change History (6)

comment:1 Changed 3 months ago by phplearner

I am newbie to computer programming and NOT a native English speaker. So if there is any detailed needed to find the solution, please do not hesitate to ask me for and excuse me for poor English.

comment:2 Changed 3 months ago by boklm

Priority: ImmediateMedium
Resolution: wontfix
Severity: CriticalNormal
Status: newclosed
Version: Tor: unspecified

5.5.2 is a very old version, and automatic updates from such an old version is not supported. To install the latest version, you can download it from the website at https://www.torproject.org/download/.

comment:3 Changed 3 months ago by phplearner

The problem is not version of tor I updated from. If I update from any version before 8.5.4 to 8.5.4 version this problem occurs. Even if I download 8.5.4 directly and extract the file, it will not starts on my system.

Last edited 3 months ago by phplearner (previous) (diff)

comment:4 Changed 3 months ago by phplearner

Resolution: wontfix
Status: closedreopened

comment:5 in reply to:  2 Changed 3 months ago by phplearner

Replying to boklm:

5.5.2 is a very old version, and automatic updates from such an old version is not supported. To install the latest version, you can download it from the website at https://www.torproject.org/download/.

The problem is not version of tor I updated from. If I update from any version before 8.5.4 to 8.5.4 version this problem occurs. Even if I download 8.5.4 directly and extract the file, it will not starts on my system.

comment:6 Changed 3 months ago by mcs

Status: reopenedneeds_information
Summary: Tor Browser do not start after update to 8.5.4Tor Browser 8.5.4 will not start up

What system are you using? (uname -a and cat /etc/lsb-release should provide useful info)

Are you using a clean copy of 8.5.4 (that is, one that you downloaded from https://dist.torproject.org/torbrowser/8.5.4/ and then extracted into a new directory)?

What output do you see if try to start Tor Browser from a shell using ./start-tor-browser.desktop --verbose?

Note: See TracTickets for help on using tickets.