Opened 8 years ago

Closed 8 years ago

#3146 closed defect (fixed)

Vidalia 0.3.0-alpha doesn't exit when you close the window on Windows

Reported by: erinn Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On OS X this is expected behavior, but I don't think it is on Windows. And if it is, there is no menu entry that let's you "exit" Vidalia. It should either exit when the X is clicked, or give an obvious menu entry that lets you exit that way.

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by erinn

Component: - Select a componentVidalia
Owner: set to chiiph

comment:2 Changed 8 years ago by chiiph

With obvious menu entry you mean in the main menu bar?
The main problem for me is that the tray icon is hidden by Windows.

The other issue is that a regular user wouldn't want to close Vidalia by just clicking in the X button, she would want it to be a bit more complicated than that, since one mistaken click and your browser and may be IM closes all together.
I'm not sure if this is such a good idea.

comment:3 Changed 8 years ago by erinn

I think there should at least be a drop down menu entry that says "Exit" and does exactly that. Having to right or left click on the tray icon, which doesn't always display, seems counterintuitive to me, at least for how I use computers. Maybe some regular Windows users can chime in?

comment:4 Changed 8 years ago by chiiph

You mean having it in the "Tor" menu? That can work.

Another more widely used possibility would be to add an option in the settings, a checkbox: "Close to tray", with default checked.

comment:5 Changed 8 years ago by chiiph

Resolution: fixed
Status: newclosed

The fix for this is in my branch chiiph/bug3146_exit and has been merged to alpha. It'll go out with 0.3.1-alpha.

Note: See TracTickets for help on using tickets.