Opened 4 weeks ago

Closed 3 weeks ago

#31495 closed defect (fixed)

cannot configure bridges

Reported by: mcs Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: regression, tbb-needs, asn-merge, dgoulet-merge
Cc: Actual Points: .1
Parent ID: #29211 Points:
Reviewer: ahf Sponsor: Sponsor31-must

Description

When using code from tor master (Tor version 0.4.2.0-alpha-dev (git-d475d7c2fb3c0ed5), I cannot configure bridges in Tor Browser. This seems to be a very recent regression, probably caused by the changes in https://gitweb.torproject.org/tor.git/commit/?id=d475d7c2fb3c0ed5120c50011b187f6957a4f52c

The relevant portion of the control port conversation is:

SETCONF UseBridges=1 Bridge="obfs4 ..."
513 Unacceptable option value: You cannot set both UseBridges and EntryNodes.

As far as I can tell, EntryNodes is not present in any of my configuration.

Child Tickets

Change History (13)

comment:1 Changed 4 weeks ago by nickm

Keywords: regression added
Milestone: Tor: 0.4.2.x-final
Owner: set to nickm
Parent ID: #29211
Status: newaccepted

comment:2 Changed 4 weeks ago by teor

I wonder how this bug got past our unit tests?

We might have 100% test coverage, but there are obviously some tests missing.
How can we make sure that we aren't breaking other combinations of options?

comment:3 in reply to:  2 Changed 4 weeks ago by teor

Replying to teor:

I wonder how this bug got past our unit tests?

We might have 100% test coverage, but there are obviously some tests missing.
How can we make sure that we aren't breaking other combinations of options?

Stem should check a lot of useful option combinations.
But the stem CI job is current set to allow_failure, because of #29437.
So we should check that the stem CI job passes, or fails due to a timeout.

I'll add this task to #31494.

comment:4 Changed 4 weeks ago by gk

Keywords: tbb-needs added

comment:5 Changed 4 weeks ago by teor

Sponsor: Sponsor31-must

We think this is a bug in #29211, so we need to fix it for sponsor 31.

comment:6 Changed 4 weeks ago by nickm

I've got a fix for this, but I want to include tests and comments.

comment:7 Changed 4 weeks ago by nickm

See branch bug31495 with PR at https://github.com/torproject/tor/pull/1269

comment:8 Changed 4 weeks ago by nickm

Actual Points: .1
Status: acceptedneeds_review

comment:9 Changed 3 weeks ago by asn

Reviewer: ahf

comment:10 Changed 3 weeks ago by asn

I encountered this today on my TB and used the branch to fix it successfully. Haven't reviewed the code, but the patch def works.

comment:11 Changed 3 weeks ago by ahf

Status: needs_reviewmerge_ready

Patches looks good.

comment:12 Changed 3 weeks ago by nickm

Keywords: asn-merge dgoulet-merge added

comment:13 Changed 3 weeks ago by asn

Resolution: fixed
Status: merge_readyclosed

merged!

Note: See TracTickets for help on using tickets.