Opened 15 months ago

Closed 8 months ago

#31499 closed defect (fixed)

Update libevent to 2.1.11-stable

Reported by: cypherpunks Owned by: sisbell
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam202004R
Cc: sysrqb, boklm, tbb-team Actual Points:
Parent ID: #28704 Points: 1
Reviewer: boklm, gk Sponsor:

Child Tickets

Change History (15)

comment:1 Changed 15 months ago by gk

Keywords: tbb-rbm added

comment:2 Changed 8 months ago by sisbell

Cc: sysrqb boklm cypherpunks added
Status: newneeds_review

With version 2.1.11 we don't need the osx patch anymore. The patch is included in the updated libevent version. The project builds across platforms

  • windows x86_64 and i686
  • osx,
  • linux x86_64 and i686.

https://github.com/sisbell/tor-browser-build/commits/bug-31499a

comment:3 Changed 8 months ago by sisbell

Cc: sisbell added

comment:4 Changed 8 months ago by sysrqb

Cc: tbb-team added; cypherpunks sisbell removed
Owner: changed from tbb-team to sisbell
Status: needs_reviewassigned

comment:5 Changed 8 months ago by sysrqb

Reviewer: boklm, gk
Status: assignedneeds_review

The patch looks good to me, but I'd like a second review.

comment:6 Changed 8 months ago by sysrqb

(specifically, commit c2fdb4de8a0468a29c18579a8b13042537f9f6c9).

comment:7 Changed 8 months ago by boklm

Keywords: TorBrowserTeam202004 added
Status: needs_reviewneeds_revision

I tried building tor for linux-x86_64 with this patch, but it failed with:

cp: cannot stat `/var/tmp/dist/libevent/lib/libevent-2.1.so.6': No such file or directory

comment:8 Changed 8 months ago by sysrqb

ugh. I almost asked about that. I noticed the last time we bumped the version we did:

diff --git a/projects/tor/build b/projects/tor/build
index bf7db832..c6d9895d 100644
--- a/projects/tor/build
+++ b/projects/tor/build
@@ -39,7 +39,7 @@ openssldir=/var/tmp/dist/openssl
   mkdir -p "$distdir/Debug/Tor"
   cp $openssldir/lib/libssl.so.1.0.0 "$distdir/Tor/"
   cp $openssldir/lib/libcrypto.so.1.0.0 "$distdir/Tor/"
-  cp $libeventdir/lib/libevent-2.0.so.5 "$distdir/Tor/"
+  cp $libeventdir/lib/libevent-2.1.so.6 "$distdir/Tor/"
   # We need to copy the libstdc++.so.6 for Tor Browser on older Linux distros.
   # Copying it into /Browser, which feels more natural, and amending
   # LD_LIBRARY_PATH breaks updates from a Tor Browser with the old

sisbell, all of your testbuilds were successful?

comment:9 in reply to:  8 Changed 8 months ago by sisbell

Replying to sysrqb:

ugh. I almost asked about that. I noticed the last time we bumped the version we did:

diff --git a/projects/tor/build b/projects/tor/build
index bf7db832..c6d9895d 100644
--- a/projects/tor/build
+++ b/projects/tor/build
@@ -39,7 +39,7 @@ openssldir=/var/tmp/dist/openssl
mkdir -p "$distdir/Debug/Tor"
cp $openssldir/lib/libssl.so.1.0.0 "$distdir/Tor/"
cp $openssldir/lib/libcrypto.so.1.0.0 "$distdir/Tor/"
-  cp $libeventdir/lib/libevent-2.0.so.5 "$distdir/Tor/"
+  cp $libeventdir/lib/libevent-2.1.so.6 "$distdir/Tor/"
# We need to copy the libstdc++.so.6 for Tor Browser on older Linux distros.
# Copying it into /Browser, which feels more natural, and amending
# LD_LIBRARY_PATH breaks updates from a Tor Browser with the old

sisbell, all of your testbuilds were successful?
I did go through each build including linux-x86_64, but I try again and see if I can reproduce this issue

comment:10 Changed 8 months ago by boklm

With the update libevent-2.1.so.6 is now libevent-2.1.so.7:

lrwxrwxrwx root/root         0 2019-08-01 23:37 libevent/lib/libevent-2.1.so.7 -> libevent-2.1.so.7.0.0
-rwx------ root/root   1639593 2019-08-01 23:37 libevent/lib/libevent-2.1.so.7.0.0

comment:11 Changed 8 months ago by pili

Points: 1

comment:12 Changed 8 months ago by boklm

Parent ID: #28765

comment:13 Changed 8 months ago by sisbell

Parent ID: #28765#28704

Changing parent ticket since it says max parent child depth too deep (over 5) whenever I try to comment

comment:14 Changed 8 months ago by sisbell

Keywords: TorBrowserTeam202004R added; TorBrowserTeam202004 removed
Status: needs_revisionneeds_review

I added the tor project change regarding libevent-2.1.so.7 to this ticket

https://github.com/sisbell/tor-browser-build/commits/bug-31499d

comment:15 in reply to:  14 Changed 8 months ago by boklm

Resolution: fixed
Status: needs_reviewclosed

Replying to sisbell:

I added the tor project change regarding libevent-2.1.so.7 to this ticket

https://github.com/sisbell/tor-browser-build/commits/bug-31499d

Thanks, this looks good to me. I merged the commit to master with commit a017df805383561dde058f566255d709bc347834.

Note: See TracTickets for help on using tickets.