#31508 closed task (not a bug)

config refactor: create simple summaries for each refactor step

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: network-team-roadmap-august, 042-deferred-20190918
Cc: nickm, teor, gaba Actual Points:
Parent ID: #29211 Points:
Reviewer: Sponsor: Sponsor31-can

Description

It would be helpful to have a quick summary showing the ideal state, and where we are in the refactor.

For example, the #30914 original state was:

  • confparse
    • typed_var

And the final state was:

  • confparse
    • struct_var
      • typed_var

Child Tickets

Change History (2)

comment:1 Changed 11 months ago by nickm

Keywords: 042-deferred-20190918 added
Milestone: Tor: 0.4.2.x-finalTor: 0.4.3.x-final

Defer numerous 0.4.2 tickets to 0.4.3.

comment:2 Changed 10 months ago by nickm

Resolution: not a bug
Status: assignedclosed

I believe this is an ongoing requirement, not a specific task; please reopen if I am wrong there?

Note: See TracTickets for help on using tickets.