Opened 4 months ago

Closed 6 weeks ago

#31509 closed defect (not a bug)

config refactor: make test-stem should pass

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.4.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: network-team-roadmap-august, 042-deferred-20190918
Cc: nickm, teor, gaba Actual Points:
Parent ID: #29211 Points:
Reviewer: Sponsor: Sponsor31-must

Description

Stem should check a lot of useful option combinations.

But the stem CI job is current set to allow_failure, because of #29437.

So we should check that the stem CI job passes, or fails due to a timeout. Or we should run "make test-stem" manually on each PR.

Child Tickets

Change History (7)

comment:1 Changed 4 months ago by teor

On master, "make test-stem" passes all the tor tests, but fails due to bugs in stem that are unrelated to tor (#31510).

On #31240, "make test-stem" passes all the tor tests, but fails due to bugs in stem that are unrelated to tor (#31510).

comment:2 Changed 4 months ago by nickm

Should this still be assigned to me? The issues here are (you say) all stem bugs.

comment:3 Changed 4 months ago by teor

Owner: nickm deleted

We should make sure that every PR passes make test-stem, because CI cant do that for us right now.

comment:4 Changed 3 months ago by nickm

Keywords: 042-deferred-20190918 added
Milestone: Tor: 0.4.2.x-finalTor: 0.4.3.x-final

Defer numerous 0.4.2 tickets to 0.4.3.

comment:5 Changed 8 weeks ago by nickm

Resolution: not a bug
Status: assignedclosed

I believe this is an ongoing requirement, not a specific task. Please reopen if that's wrong?

comment:6 Changed 8 weeks ago by teor

Resolution: not a bug
Status: closedreopened

We don't know if make test-stem passes, because it is broken on our CI.
See #30901.

comment:7 Changed 6 weeks ago by teor

Resolution: not a bug
Status: reopenedclosed

I will regularly run "make test-stem", as it doesn't work for other people.

Note: See TracTickets for help on using tickets.