Opened 9 years ago

Closed 8 years ago

#3156 closed enhancement (fixed)

The UI could more usefully inform users about mis-set clocks

Reported by: bia7 Owned by:
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Tor: 0.2.2.25-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After changing my pc time manually one hour ahead to comply with the DST change in my country, Tor could not find any .onion sites (WWW still works)

All the information I could get was a warning from the message log:
May 12 21:26:37.484 [Warning] Received directory with skewed time (server '216.224.124.114:9090'): It seems that our clock is ahead by 1 hours, 1 minutes, or that theirs is behind. Tor requires an accurate clock to work: please check your time, timezone, and date settings.
Which in fact drove me to the solution, by reverting the time.

However, this is not clear enough to the average user, so either there is a bug with handling manual time, or the user needs to be made aware that he must set the clock automatically.

Child Tickets

Attachments (1)

Copy of tor-log2.txt (582.7 KB) - added by bia7 9 years ago.
Message log of problematic state

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by bia7

Attachment: Copy of tor-log2.txt added

Message log of problematic state

comment:1 in reply to:  description Changed 9 years ago by rransom

Resolution: not a bug
Status: newclosed

Replying to bia7:

After changing my pc time manually one hour ahead to comply with the DST change in my country, Tor could not find any .onion sites (WWW still works)

Don't do that then.

The correct way to make your computer aware of daylight savings time is to configure your operating system's time zone settings properly, not adjust its clock.

comment:2 Changed 9 years ago by arma

So far as I know, Tor handles changed clocks fine. The fact that Tor still thought your clock was wrong makes me think your clock was wrong.

My guess is that your system clock automatically adjusted itself, *and* you manually changed it by an hour. Or some other user error.

comment:3 Changed 9 years ago by bia7

Resolution: not a bug
Status: closedreopened

These are brilliant responses.
Nonetheless, people are actually LEGALLY ALLOWED to change the clock on their PC.
And Tor says NOTHING about it disabling .onion access, I was stuck on this issue for over a month, and I'm sure others are as well.
Why close this and not at least act on my other suggestion to make the user AWARE that this is the problem??
This is a very big issue, please don't just disregard it.

comment:4 in reply to:  3 ; Changed 9 years ago by arma

Replying to bia7:

Nonetheless, people are actually LEGALLY ALLOWED to change the clock on their PC.

You're allowed to change your clock, but if you change it to the wrong time, Tor features will start breaking. This is a security feature, to prevent people from partitioning you if you have a different network view than other users.

And Tor says NOTHING about it disabling .onion access, I was stuck on this issue for over a month, and I'm sure others are as well.
Why close this and not at least act on my other suggestion to make the user AWARE that this is the problem??
This is a very big issue, please don't just disregard it.

Well, we do say tell you to fix your clock on https://torproject.org/docs/faq#DoesntWork

And the warning message you saw in your logs also triggers a new entry in Vidalia's simplified message window.

I agree that neither of these are perfect. How else should we try to make the user aware that a wrong clock equals a not-working Tor?

comment:5 in reply to:  4 Changed 9 years ago by bia7

Replying to arma:
Thanks for the reply arma,
The situation of Tor needing a well adjusted clock to run is not optimal, but tolerable.
The issue at hand here is a user that connects to Tor, thinking the client is working perfectly by all the indicators he was given in Vidalia, but in fact he cannot access onion sites.
Searching the FAQ is definitely not a good way to solve this.
The best solution I can think of is having the Vidalia Control Panel indicator set to yellow and not green on connection. This will get the user's attention and with the correct status message ("Limited connectivity to the Tor network (PC Clock is not accurate enough)" - which is correct, www is available.) it will direct the user to the problem itself.

comment:6 Changed 8 years ago by nickm

Component: Tor ClientVidalia
Priority: majornormal
Summary: Tor does not find .onion sites when manually setting pc clockThe UI could more usefully inform users about mis-set clocks
Type: defectenhancement

comment:7 Changed 8 years ago by chiiph

Resolution: fixed
Status: reopenedclosed

This is fixed in my branch chiiph/bug3156_clock and has been merged against alpha. It'll go in 0.3.1-alpha.

Note: See TracTickets for help on using tickets.