Opened 3 weeks ago

Closed 2 weeks ago

#31563 closed defect (fixed)

Urlbar search icons disappear after browser restart

Reported by: acat Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff68-esr, TorBrowserTeam201908R, tbb-9.0-must-alpha
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Patch for #30845 fixes this issue on a fresh profile, but not on an already existing profile which was already restarted at least once. On top of that, there is a quite surprising behaviour:

  1. Open Tor Browser ESR68 without patch for #30845.
  2. Restart browser.
  3. Check that search icons have disappeared.
  4. Change pref from #30845 and restart.
  5. Urlbar is unusable, and browser console shows:
1567091784597	addons.xpi-utils	WARN	Synchronous load of XPI database due to getAddonsByType([theme]) Stack: getAddonsByType@resource://gre/modules/addons/XPIDatabase.jsm:1997:21
installBuiltinAddon@resource://gre/modules/addons/XPIInstall.jsm:4283:24
_openNetworkSettings@jar:file:///tor-browser_en-US/Browser/browser/omni.ja!/chrome/torlauncher/components/tl-process.js:749:11
_controlTor@jar:file:///tor-browser_en-US/Browser/browser/omni.ja!/chrome/torlauncher/components/tl-process.js:584:14
TorStartAndControlTor@jar:file:///tor-browser_en-US/Browser/browser/omni.ja!/chrome/torlauncher/components/tl-process.js:331:10
observe@jar:file:///tor-browser_en-US/Browser/browser/omni.ja!/chrome/torlauncher/components/tl-process.js:133:14

which might be related, but did not investigate yet.

Child Tickets

Change History (7)

comment:1 Changed 3 weeks ago by acat

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 2 weeks ago by cypherpunks

  1. Check that search icons have disappeared.

I.e. some functionality has been removed. Changing prefs can't restore it.

comment:4 Changed 2 weeks ago by acat

Keywords: TorBrowserTeam201908R added; TorBrowserTeam201908 removed
Status: newneeds_review

There seems to be two different paths for loading search engines: from cache and from scratch. Initially they are loaded from scratch, and this seems to ignore extensions.enabledScopes, so the search extensions are installed and that's why it works on first time. After restart, engines are loaded from cache and in that case I think extensions.enabledScopes is enforced and previously installed search extensions are disabled (the icons are a moz-extension:// resource and that's probably why they disappear, because the extension is not enabled).

The patch in https://github.com/acatarineu/tor-browser/commit/31563 forces reloading the search extensions if extensions.enabledScopes in the cache has changed, and fixes the engines when switching from 1 to 5 and restarting the browser.

comment:5 Changed 2 weeks ago by gk

While testing manually I still get on first re-start no icons. Does that work for you now? However, on the second restart everything is as it should with your patch. So, I cherry-picked it to tor-browser-68.1.0esr-9.0-1 (commit dc1c60e81e6d23560d597c390eed48b2331f005c).

I tested on a Linux bundle by manually patching the files in the respective omni.ja files: first making sure we start with enabledSopes set to 1 and then after quitting applying your patch and setting enabledScopes to 5. Then I cleared the startupCache and restarted showing the missing search icons. After another restart everything worked fine.

comment:6 Changed 2 weeks ago by acat

I think I tested both in Firefox (since I had filed the bugzilla ticket) and Tor Browser, but perhaps I followed a different sequence of actions.

Now testing again in Tor Browser, on first restart after setting enabledScopes to 5 and applying the patch I actually have the issue of the urlbar not working (which seems to be correlated with the tor-launcher error log mentioned in the description). Opening a new window or restarting the browser fixes it, and icons are also shown. So search extensions seem to be installed, and urlbar being broken seems like a separate issue probably unique to Tor Browser. Do you also have the issue of urlbar being broken, or it's just the icons not shown? I can't reproduce icons not being shown after setting enabledScopes to 5 and applying the patch.

comment:7 in reply to:  6 Changed 2 weeks ago by gk

Resolution: fixed
Status: needs_reviewclosed

Replying to acat:

I think I tested both in Firefox (since I had filed the bugzilla ticket) and Tor Browser, but perhaps I followed a different sequence of actions.

Now testing again in Tor Browser, on first restart after setting enabledScopes to 5 and applying the patch I actually have the issue of the urlbar not working (which seems to be correlated with the tor-launcher error log mentioned in the description). Opening a new window or restarting the browser fixes it, and icons are also shown. So search extensions seem to be installed, and urlbar being broken seems like a separate issue probably unique to Tor Browser. Do you also have the issue of urlbar being broken, or it's just the icons not shown?

The URL bar is broken for me. So, yes, could you open a new bug for that (and probably Cc mcs and brade). I recall that I had some other weird URL bar brokeness (same symptoms) during normal browsing with nightly builds during the last week. Might be more to it. Anyway, I think we are done here, thanks.

Note: See TracTickets for help on using tickets.