Opened 7 weeks ago

Closed 5 weeks ago

Last modified 3 weeks ago

#31570 closed defect (fixed)

INTERNAL ERROR: raw assertion failed (core dump) in termux

Reported by: foremtehan Owned by: nickm
Priority: High Milestone: Tor: 0.4.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 042-should, regression?, mmap, android, crash BugSmashFund dgoulet-merge 041-backport
Cc: Actual Points: .1
Parent ID: Points:
Reviewer: ahf Sponsor:

Description

So, I have fresh install of termux in my phone no matter if i reinstall the termux tor will crash in start does anybudy can track it down ?

==============================================================T= 1567005970
INTERNAL ERROR: Raw assertion failed at /home/builder/.termux-build/tor/src/src/lib/malloc/map_anon.c:213: nodump_result == 0Aborted (core dumped)

Additional information:

https://github.com/termux/termux-packages/issues/4235
https://tor.stackexchange.com/questions/20222/internal-error-raw-assertion

Child Tickets

Change History (16)

comment:1 Changed 7 weeks ago by gk

Component: - Select a componentCore Tor/Tor

comment:2 Changed 7 weeks ago by teor

Keywords: 042-should regression? mmap android added
Milestone: Tor: 0.4.2.x-final
Status: newneeds_information

There's a lot of info in those links, but I can't find the tor version you're using?

I think we fixed a similar mmap bug recently, we'll know if we can find you what version you're using.

There's also a missing newline and tor version bug in the logs here, so raw_assert() also has some bugs. I'll open a child ticket.

comment:3 in reply to:  2 Changed 7 weeks ago by teor

Replying to teor:

There's a lot of info in those links, but I can't find the tor version you're using?

You'll have to let us know, it's definitely not in these logs.

There's also a missing newline and tor version bug in the logs here, so raw_assert() also has some bugs. I'll open a child ticket.

I made sure it will be in future logs, see #31571.

comment:4 in reply to:  2 ; Changed 7 weeks ago by foremtehan

Replying to teor:

we'll know if we can find you what version you're using.

I installed tor through termux by "pkg install tor", I found the version (0.4.1.5):

https://i.imgur.com/1IVlFNt.png

How to install last version of tor by "pkg"?

There's also a missing newline and tor version bug in the logs here, so raw_assert() also has some bugs. I'll open a child ticket.

Is there anything I need to do؟

Last edited 7 weeks ago by foremtehan (previous) (diff)

comment:5 in reply to:  4 Changed 7 weeks ago by teor

Owner: set to nickm
Status: needs_informationassigned

Replying to foremtehan:

Replying to teor:

we'll know if we can find you what version you're using.

I installed tor through termux by "pkg install tor", I found the version (0.4.1.5):

https://i.imgur.com/1IVlFNt.png

Thanks!

I've assigned this bug to nickm, because he wrote this code.

How to install last version of tor by "pkg"?

I don't know which tor versions are available via pkg, check its package index?

Let's see if nickm can diagnose the bug, and tell you if it is fixed.
Then we will know which version to tell you to install.

There's also a missing newline and tor version bug in the logs here, so raw_assert() also has some bugs. I'll open a child ticket.

Is there anything I need to do؟

No, we will take care of fixing logging, and make sure it gets into a tor release eventually.

comment:6 Changed 7 weeks ago by nickm

Priority: MediumHigh

comment:7 Changed 6 weeks ago by nickm

Actual Points: .1
Status: assignedneeds_review

So, this appears to be happening because madvise() is failing, which shouldn't be able to happen, but which might be possible. I wonder what the errno value is. My guesses would be ENOSYS or EINVAL.

I have a possible fix in a branch bug31570_041. (If the issue isn't fixed, it should at least have a slightly better log message.) PR at https://github.com/torproject/tor/pull/1285 .

It would be good if somebody could test this patch on an affected system, but I think it should be clear enough that we could try merging it anyway.

comment:8 in reply to:  7 Changed 6 weeks ago by foremtehan

Replying to nickm:

It would be good if somebody could test this patch on an affected system, but I think it should be clear enough that we could try merging it anyway.

Thanks for the debug, I'll try it as soon as it merge on the repo

comment:9 Changed 6 weeks ago by nickm

Keywords: crash added

Add "crash" keyword to defect tickets in 0.4.2 that don't have it.

comment:10 Changed 5 weeks ago by dgoulet

Reviewer: ahf

comment:11 Changed 5 weeks ago by nickm

Keywords: BugSmashFund added

comment:12 Changed 5 weeks ago by ahf

Status: needs_reviewmerge_ready

Patch looks good. I was not able to trigger the error case here on my machine though.

comment:13 Changed 5 weeks ago by nickm

Keywords: dgoulet-merge added

comment:14 Changed 5 weeks ago by dgoulet

Resolution: fixed
Status: merge_readyclosed

Merged!

comment:15 Changed 4 weeks ago by nickm

Keywords: 041-backport added
Milestone: Tor: 0.4.2.x-finalTor: 0.4.1.x-final

Backported to 0.4.1

comment:16 Changed 3 weeks ago by foremtehan

I installed the new version of tor on the termux and the error was gone thank you guys!

Note: See TracTickets for help on using tickets.