Opened 7 weeks ago

Closed 5 weeks ago

#31578 closed defect (fixed)

practracker scans build directories inside the tor/ directory

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.4.2.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: practracker, regression?, 042-should, dgoulet-merge
Cc: Actual Points: 0.1
Parent ID: Points: 0.1
Reviewer: asn Sponsor: Sponsor31-can

Description

When I run practracker after the failed "make distcheck" in #31577, I get these errors:

problem function-size /build-c/tor-0.4.2.0-alpha-dev/src/trunnel/socks5.c:socks4_client_request_encode() 352
problem function-size /build-c/tor-0.4.2.0-alpha-dev/src/trunnel/socks5.c:socks4_client_request_parse_into() 332
problem function-size /build-c/tor-0.4.2.0-alpha-dev/src/trunnel/socks5.c:socks5_client_request_encode() 113
problem function-size /build-c/tor-0.4.2.0-alpha-dev/src/trunnel/socks5.c:socks5_server_reply_encode() 113
problem file-size /build-c/tor-0.4.2.0-alpha-dev/src/trunnel/socks5.h 995
problem function-size /build-c/tor-0.4.2.0-alpha-dev/src/trunnel/hs/cell_introduce1.c:trn_cell_introduce_encrypted_encode() 110
(warning) problem file-size /src/core/or/circuitpadding.c 3096
(warning) problem function-size /src/core/or/circuitpadding.c:circpad_machine_schedule_padding() 113
(warning) problem file-size /src/core/or/circuitpadding.h 813
(warning) problem file-size /src/core/or/relay.c 3264
(warning) problem file-size /src/feature/hs/hs_service.c 4125
(warning) problem file-size /src/feature/nodelist/routerlist.c 3241
(warning) problem function-size /src/feature/rend/rendmid.c:rend_mid_establish_intro_legacy() 105
(warning) problem file-size /src/feature/rend/rendservice.c 4522
(warning) problem function-size /src/feature/rend/rendservice.c:rend_service_receive_introduction() 334
FAILURE: practracker found 482 new problem(s) in the code: see warnings above.

Please fix the problems if you can, and update the exceptions file
(../scripts/maint/practracker/./exceptions.txt) if you can't.

See doc/HACKING/HelpfulTools.md for more information on using practracker.
You can disable this message by setting the TOR_DISABLE_PRACTRACKER environment
variable.

make[1]: *** [check-best-practices] Error 226
make[1]: *** Waiting for unfinished jobs....

Child Tickets

Change History (8)

comment:1 Changed 7 weeks ago by nickm

I can fix this unless somebody else wants to.

comment:2 Changed 7 weeks ago by teor

Parent ID: #31577

Go for it :-)

comment:3 Changed 7 weeks ago by nickm

Owner: set to nickm
Status: newaccepted

comment:4 Changed 6 weeks ago by nickm

Actual Points: .1
Status: acceptedneeds_review

Fix in branch ticket31578; PR at https://github.com/torproject/tor/pull/1286

comment:5 Changed 5 weeks ago by dgoulet

Reviewer: asn

comment:6 Changed 5 weeks ago by asn

Status: needs_reviewmerge_ready

LGTM and seems to work fine in my testing.

comment:7 Changed 5 weeks ago by nickm

Keywords: dgoulet-merge added

comment:8 Changed 5 weeks ago by dgoulet

Actual Points: .10.1
Points: 0.1
Resolution: fixed
Status: merge_readyclosed

I've merged nickm/ticket31578_merged that nickm made since it had a conflict with upstream.

Diff was good from the PR.

Note: See TracTickets for help on using tickets.